summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2017-01-17 20:07:06 +0000
committerAlex Kost <alezost@gmail.com>2017-01-18 12:57:23 +0300
commitcf006d2e738f473e7fb630b566e04c4872fa204b (patch)
tree68da84a1a59ea57b030e458a796b7f2996f59d05 /gnu/packages/emacs.scm
parent12b8f6b4012b47d849ba8b6cfa80abb2a5263e19 (diff)
downloadguix-patches-cf006d2e738f473e7fb630b566e04c4872fa204b.tar
guix-patches-cf006d2e738f473e7fb630b566e04c4872fa204b.tar.gz
gnu: Add emacs-ag.
* gnu/packages/emacs.scm (emacs-ag): New variable. Signed-off-by: Alex Kost <alezost@gmail.com>
Diffstat (limited to 'gnu/packages/emacs.scm')
-rw-r--r--gnu/packages/emacs.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index e784a9ea13..e11039a8a5 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -17,6 +17,7 @@
;;; Copyright © 2016 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2016 Alex Vong <alexvong1995@gmail.com>
;;; Copyright © 2016 Arun Isaac <arunisaac@systemreboot.net>
+;;; Copyright © 2017 Christopher Baines <mail@cbaines.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -46,6 +47,7 @@
#:use-module (guix build-system glib-or-gtk)
#:use-module (guix build-system trivial)
#:use-module (gnu packages)
+ #:use-module (gnu packages code)
#:use-module (gnu packages guile)
#:use-module (gnu packages gtk)
#:use-module (gnu packages gnome)
@@ -1066,6 +1068,44 @@ like. It can be linked with various Emacs mail clients (Message and Mail
mode, Rmail, Gnus, MH-E, and VM). BBDB is fully customizable.")
(license license:gpl3+)))
+(define-public emacs-ag
+ (package
+ (name "emacs-ag")
+ (version "0.47")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/Wilfred/ag.el/archive/"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1rlmp6wnyhqfg86dbz17r914msp58favn4kd4yrdwyia265a4lar"))))
+ (build-system emacs-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'install 'patch-exec-paths
+ (lambda* (#:key inputs #:allow-other-keys)
+ (emacs-substitute-variables "ag.el"
+ ("ag-executable"
+ (string-append (assoc-ref inputs "the-silver-searcher")
+ "/bin/ag")))
+ #t)))))
+ (inputs
+ `(("the-silver-searcher" ,the-silver-searcher)))
+ (propagated-inputs
+ `(("dash" ,emacs-dash)
+ ("s" ,emacs-s)))
+ (home-page "https://github.com/Wilfred/ag.el")
+ (synopsis "Front-end for ag (the-silver-searcher) for Emacs")
+ (description "This package provides the ability to use the silver
+searcher, a code searching tool, sometimes abbreviated to @code{ag}. Features
+include version control system awareness, use of Perl compatible regular
+expressions, editing the search results directly and searching file names
+rather than the contents of files.")
+ (license license:gpl3+)))
+
(define-public emacs-async
(package
(name "emacs-async")