summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs.scm
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2018-09-11 23:45:06 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2018-09-11 23:53:35 +0200
commitee0d184502cf893058ff250e9df159f6405d30ce (patch)
tree43234145e834d9e89e221c31ea539c3033669cb5 /gnu/packages/emacs.scm
parentbd8f74dfbe51308fbd9a61281d9a63ef09d5ab4f (diff)
downloadguix-patches-ee0d184502cf893058ff250e9df159f6405d30ce.tar
guix-patches-ee0d184502cf893058ff250e9df159f6405d30ce.tar.gz
gnu: Add emacs-hackernews.
* gnu/packages/emacs.scm (emacs-hackernews): New variable.
Diffstat (limited to 'gnu/packages/emacs.scm')
-rw-r--r--gnu/packages/emacs.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index a84ef81859..7b2929cadc 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -11797,3 +11797,27 @@ hiding the symbolic links and fontified based on whether content is present.
Commands for performing some common operations (e.g., unlocking and adding
files) are provided.")
(license license:gpl2+))))
+
+(define-public emacs-hackernews
+ (let ((commit "d8c450bbc76d6bb65ec5cdb6c3b888a23f3769e9"))
+ (package
+ (name "emacs-hackernews")
+ (version (git-version "0.4.0" "1" commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/clarete/hackernews.el")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "06mp4n6c300jv5lhwf50ircfjckzr2p1zd38s4mqnxxjlf1maim7"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/clarete/hackernews.el")
+ (synopsis "Hacker News client for Emacs")
+ (description "The @command{hackernews} package is able to fetch stories
+from six different Hacker News feeds, namely top, new, best, ask, show and job
+stories. The default feed is top stories, which corresponds to the Hacker
+News homepage.")
+ (license license:gpl3))))