summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs.scm
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2017-04-11 23:47:22 +0530
committerKei Kebreau <kei@openmailbox.org>2017-04-11 14:44:20 -0400
commit25e810b8128412fdaea812ed4ff2edf507534b42 (patch)
treef1a1405fff43a89026b792d210a2970d2c25a930 /gnu/packages/emacs.scm
parent8ad5a20f41f7333049d7a1f371b4a4a66ce16e8a (diff)
downloadguix-patches-25e810b8128412fdaea812ed4ff2edf507534b42.tar
guix-patches-25e810b8128412fdaea812ed4ff2edf507534b42.tar.gz
gnu: Add emacs-htmlize.
* gnu/packages/emacs.scm (emacs-htmlize): New variable. Signed-off-by: Kei Kebreau <kei@openmailbox.org>
Diffstat (limited to 'gnu/packages/emacs.scm')
-rw-r--r--gnu/packages/emacs.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index c7d28d37a4..aa41e8c63f 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -4257,3 +4257,25 @@ sign messages that you send. For details and instructions on how to use
DefaultEncrypt, please refer to the home page or read the comments in the
source file, @file{jl-encrypt.el}.")
(license license:gpl3+)))
+
+(define-public emacs-htmlize
+ (package
+ (name "emacs-htmlize")
+ (version "1.51")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/hniksic/emacs-htmlize/archive/release/"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1fy1lybzrxl8a8r88f6p19nz8ygmvcxhxbnymkxh7jqaz25viwld"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/hniksic/emacs-htmlize")
+ (synopsis "Convert buffer text and decorations to HTML")
+ (description "@code{emacs-htmlize} converts the buffer text and
+the associated decorations to HTML. Output to CSS, inline CSS and
+fonts is supported.")
+ (license license:gpl2+)))