summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
authorAlex ter Weele <alex.ter.weele@gmail.com>2019-12-19 21:36:33 -0500
committerBrett Gilio <brettg@gnu.org>2019-12-20 19:36:10 -0600
commit5613760aa40a157eb7f6666abbe8f5a9484c8b42 (patch)
treee5aba76f2c15b75fce5b0094e75e48446f271668 /gnu/packages/emacs-xyz.scm
parent47ec01382784eeb859ca3ce69862333a629e3c61 (diff)
downloadguix-patches-5613760aa40a157eb7f6666abbe8f5a9484c8b42.tar
guix-patches-5613760aa40a157eb7f6666abbe8f5a9484c8b42.tar.gz
gnu: Add emacs-punpun-theme.
* gnu/packages/emacs-xyz.scm (emacs-punpun-theme): New variable. Signed-off-by: Brett Gilio <brettg@gnu.org>
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 8ff7a23f51..ded4a55cb7 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -19876,6 +19876,30 @@ is cast on a light backdrop (Modus Operandi) and another where light text is
displayed against a dark background (Modus Vivendi).")
(license license:gpl3+)))
+(define-public emacs-punpun-theme
+ (let ((commit "2f78125609277b2478abdebd8f9d5ee10a823b65")
+ (revision "0"))
+ (package
+ (name "emacs-punpun-theme")
+ (version (git-version "0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/wasamasa/punpun-theme.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1sgxrj3igzq86h3whfymxf4qzv9kpvcrlhbvjmnp7fwrplys0n7d"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/wasamasa/punpun-theme")
+ (synopsis "Bleak Emacs theme")
+ (description
+ "A bleak theme. Uses shades of gray and the occasional splash of
+color. Designed for 256-color terminals. Comes in light and dark!")
+ (license license:gpl3+))))
+
(define-public emacs-elixir-mode
(package
(name "emacs-elixir-mode")