summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2021-08-29 17:25:56 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2021-08-29 17:34:43 +0300
commit5fdc46a9fe6233060a7817322eab2b1ad339deae (patch)
treea79c2d6fb34924137ddf67946666afeaf8b58512 /gnu/packages/emacs-xyz.scm
parent8fe8f534545ee3ae40945a7bc8b5a29b3af46cdc (diff)
downloadguix-patches-5fdc46a9fe6233060a7817322eab2b1ad339deae.tar
guix-patches-5fdc46a9fe6233060a7817322eab2b1ad339deae.tar.gz
gnu: Add emacs-hideshowvis.
* gnu/packages/emacs-xyz.scm (emacs-hideshowvis): New variable.
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index c4e632d820..4ff4c02187 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -18873,6 +18873,28 @@ blank slate) and is clearly highlighted with respect to the rest of the
buffer.")
(license license:gpl2+)))
+(define-public emacs-hideshowvis
+ (let ((commit "614e856620445166a60c00a1c4653dbd59c871c9")
+ (revision "1"))
+ (package
+ (name "emacs-hideshowvis")
+ (version (git-version "0.7" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/sheijk/hideshowvis")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0ykj5jwcm03p5h7sd52qndmzihyan09lqg6rzgmyabvw7p56y90m"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/sheijk/hideshowvis")
+ (synopsis "Add icons in the Emacs fringe which @code{hideshow} can hide")
+ (description "Emacs package to add clickable icons in the fringe for
+regions which @code{hideshow} can hide.")
+ (license license:gpl2+))))
+
(define-public emacs-know-your-http-well
(package
(name "emacs-know-your-http-well")