summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
authorDimakakos Dimos <bendersteed@teknik.io>2019-06-12 16:26:04 +0300
committerLudovic Courtès <ludo@gnu.org>2019-06-13 23:23:28 +0200
commit576cb396eac4e8cea2b54d96382f8e77f3584e89 (patch)
tree1775153991ae818f98d66e3d32ece940a365b7b2 /gnu/packages/emacs-xyz.scm
parent1aa2c25560328215936a9f2c52b8de8d7cc04382 (diff)
downloadguix-patches-576cb396eac4e8cea2b54d96382f8e77f3584e89.tar
guix-patches-576cb396eac4e8cea2b54d96382f8e77f3584e89.tar.gz
gnu: Add emacs-org-noter
* gnu/packages/emacs-xyz.scm (emacs-org-noter): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 77b89f8182..a8eb141452 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -15988,3 +15988,31 @@ corresponding Evil keys.")
(description "@code{xterm-color.el} is an ANSI control sequence to
text-property translator.")
(license license:bsd-2))))
+
+(define-public emacs-org-noter
+ (package
+ (name "emacs-org-noter")
+ (version "1.3.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://stable.melpa.org/packages/org-noter-"
+ version
+ ".el"))
+ (sha256
+ (base32
+ "1hczwva73gsyanl1ldhdvql01gy0hy2g861yzkaklyb763sx58x4"))))
+ (build-system emacs-build-system)
+ (propagated-inputs `(("emacs-org" ,emacs-org)))
+ (home-page
+ "https://github.com/weirdNox/org-noter")
+ (synopsis
+ "Synchronized, Org-mode, document annotator")
+ (description
+ "The idea is to let you create notes that are kept in sync when you
+scroll through the document, but that are external to it - the notes
+themselves live in an Org-mode file. As such, this leverages the power of
+Org-mode (the notes may have outlines, latex fragments, babel, etc...) while
+acting like notes that are made /in/ the document.")
+ (license license:gpl3+)))