summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2020-12-09 17:27:51 +0100
committerPierre Neidhardt <mail@ambrevar.xyz>2020-12-09 17:27:51 +0100
commita294eecd98c8237781ab0c80c3b7695b77f7ec35 (patch)
tree8894f36391c6d05ebcd689db1335354e1d586849 /gnu/packages/emacs-xyz.scm
parent51034596643a36ccbf87081736437eaef078d9cb (diff)
downloadguix-patches-a294eecd98c8237781ab0c80c3b7695b77f7ec35.tar
guix-patches-a294eecd98c8237781ab0c80c3b7695b77f7ec35.tar.gz
gnu: Add emacs-helm-switch-to-repl.
* gnu/packages/emacs-xyz.scm (emacs-helm-switch-to-repl): New variable.
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index dcf05c909d..9407a4fdc2 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -23536,6 +23536,30 @@ Google guidelines.")
fish-completion. It can be used in both Eshell and M-x shell.")
(license license:gpl3+)))
+(define-public emacs-helm-switch-to-repl
+ (package
+ (name "emacs-helm-switch-to-repl")
+ (version "0.1.0")
+ (home-page "https://github.com/emacs-helm/helm-switch-to-repl")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0n19brymwnawhi0y10m54cas3qg64pmkqq1ajvjw1rfibmw3n6nk"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("helm" ,emacs-helm)))
+ (synopsis "Helm action to switch directory in Emacs REPLs")
+ (description "Helm \"Switch-to-REPL\" offers the
+@code{helm-switch-to-repl} action, a generalized and extensible version of
+@code{helm-ff-switch-to-shell}. It can be added to @code{helm-find-files} and
+other @code{helm-type-file} sources such as @code{helm-locate}.")
+ (license license:gpl3+)))
+
(define-public emacs-telega
;; This package has versions newer than indicated on MELPA.
;; Get the current version from `telega-version` in telega.el.