summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
authorAlex Griffin <a@ajgrf.com>2019-06-09 09:00:05 -0500
committerOleg Pykhalov <go.wigust@gmail.com>2019-06-13 23:40:05 +0300
commit9989e06fda9f60dc08272435629ab9f065bb0da5 (patch)
tree6ab4c40ef14bc34d342a1cfa0366a11e80efc14b /gnu/packages/emacs-xyz.scm
parentc56a65aae7533de8d3e6fe32bb11e167cad63e22 (diff)
downloadguix-patches-9989e06fda9f60dc08272435629ab9f065bb0da5.tar
guix-patches-9989e06fda9f60dc08272435629ab9f065bb0da5.tar.gz
gnu: Add emacs-elfeed-org.
* gnu/packages/emacs-xyz.scm (emacs-elfeed-org): New variable. Signed-off-by: Oleg Pykhalov <go.wigust@gmail.com>
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm44
1 files changed, 43 insertions, 1 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 1fb8ce1da9..ef29177c8b 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -13,7 +13,7 @@
;;; Copyright © 2016 Matthew Jordan <matthewjordandevops@yandex.com>
;;; Copyright © 2016, 2017 Roel Janssen <roel@gnu.org>
;;; Copyright © 2016, 2017 ng0 <ng0@n0.is>
-;;; Copyright © 2016 Alex Griffin <a@ajgrf.com>
+;;; Copyright © 2016, 2019 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2016, 2017, 2018, 2019 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2016, 2017, 2018 Alex Vong <alexvong1995@gmail.com>
;;; Copyright © 2016, 2017, 2018, 2019 Arun Isaac <arunisaac@systemreboot.net>
@@ -5233,6 +5233,48 @@ If you want to mark a folder manually as a project just create an empty
and RSS, with a user interface inspired by notmuch.")
(license license:gpl3+)))
+(define-public emacs-elfeed-org
+ (let ((commit "77b6bbf222487809813de260447d31c4c59902c9"))
+ (package
+ (name "emacs-elfeed-org")
+ (version (git-version "0.1" "1" commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/remyhonig/elfeed-org.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0a2ibka82xq1dhy2z7rd2y9zhcj8rna8357881yz49wf55ccgm53"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-elfeed" ,emacs-elfeed)
+ ("emacs-org" ,emacs-org)
+ ("emacs-dash" ,emacs-dash)
+ ("emacs-s" ,emacs-s)))
+ (native-inputs
+ `(("ert-runner" ,emacs-ert-runner)
+ ("emacs-xtest" ,emacs-xtest)))
+ (arguments
+ `(#:tests? #t
+ #:test-command '("ert-runner" "-L" "org-mode/lisp")
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'chmod
+ (lambda _
+ (chmod "test/fixture-mark-feed-ignore.org" #o644)
+ #t)))))
+ (home-page "https://github.com/remyhonig/elfeed-org")
+ (synopsis "Configure Elfeed with an Org-mode file")
+ (description
+ "@code{elfeed-org} lets you manage your Elfeed subscriptions
+in Org-mode. Maintaining tags for all RSS feeds is cumbersome using
+the regular flat list, where there is no hierarchy and tag names are
+duplicated a lot. Org-mode makes the book keeping of tags and feeds
+much easier.")
+ (license license:gpl3+))))
+
(define-public emacs-el-x
(package
(name "emacs-el-x")