summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
authorXinglu Chen <public@yoctocell.xyz>2021-06-12 22:28:29 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-06-12 22:28:29 +0200
commit9a2e8664ecd0b7fe3371cb268506e68037b3263d (patch)
treec0d461e397f4c5e9c96e4808473d68b728f3ebec /gnu/packages/emacs-xyz.scm
parent855805aadef94285ea38aad62d528995655e17e7 (diff)
downloadguix-patches-9a2e8664ecd0b7fe3371cb268506e68037b3263d.tar
guix-patches-9a2e8664ecd0b7fe3371cb268506e68037b3263d.tar.gz
gnu: Add emacs-ytel-show.
* gnu/packages/emacs-xyz.scm (emacs-ytel-show): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 2d60c2a15d..c23e2e07c2 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -21291,6 +21291,32 @@ extracted and manipulated by user-defined functions to do various things such
as playing them in some video player, or downloading them.")
(license license:gpl3+))))
+(define-public emacs-ytel-show
+ ;; No tagged releases. Version extracted from main file.
+ (let ((commit "8b999484eb447ecdb741b24cbef2b5a7260a53e6")
+ (revision "0"))
+ (package
+ (name "emacs-ytel-show")
+ (version (git-version "0.1.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/xFA25E/ytel-show")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0nhgzfzq1bgpbdbljx5z2hzr8ia7ybsyvvr66yj4klz0zj97rghj"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-ytel" ,emacs-ytel)))
+ (home-page "https://github.com/xFA25E/ytel-show")
+ (synopsis "Browse YouTube in Emacs")
+ (description
+ "This package provides an Emacs interface for browsing YouTube videos
+and comments.")
+ (license license:gpl3+))))
+
(define-public emacs-org-web-tools
(package
(name "emacs-org-web-tools")