summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
authorZhu Zihao <all_but_last@163.com>2021-07-09 22:58:34 +0800
committerLeo Prikler <leo.prikler@student.tugraz.at>2021-07-09 17:57:10 +0200
commit2086a6a335a23ae56485592f62c77cb088d62fff (patch)
treefc5e2eb73462666a5ea25268fc8b62e520fb4ecc /gnu/packages/emacs-xyz.scm
parentcf88c967afbf15c58efb0ba37d6638f1be9a0481 (diff)
downloadguix-patches-2086a6a335a23ae56485592f62c77cb088d62fff.tar
guix-patches-2086a6a335a23ae56485592f62c77cb088d62fff.tar.gz
gnu: emacs-telega: Fix 'patch-source' phase.
* gnu/packages/emacs-xyz.scm (emacs-telega)[#:phases]<patch-sources>: Add missing slash in ‘/bin’ when patching general commands. Also patch telega-vvnote.el. Signed-off-by: Leo Prikler <leo.prikler@student.tugraz.at>
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm22
1 files changed, 11 insertions, 11 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 6ac61fd596..16cd0d8b5b 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -26290,17 +26290,17 @@ service, and connect it with Emacs via inter-process communication.")
(let* ((ffmpeg (assoc-ref inputs "ffmpeg"))
(ffmpeg-bin (string-append ffmpeg "/bin/ffmpeg"))
(ffplay-bin (string-append ffmpeg "/bin/ffplay")))
- (substitute* "telega-ffplay.el"
- (("(shell-command-to-string\|concat) \"(ffmpeg\|ffprobe)"
- all func cmd)
- (string-append func " \"" (assoc-ref inputs "ffmpeg")
- "bin/" cmd))
- (("\\(executable-find \"ffplay\"\\)")
- (string-append "(and (file-executable-p \"" ffplay-bin "\")"
- "\"" ffplay-bin "\")"))
- (("\\(executable-find \"ffmpeg\"\\)")
- (string-append "(and (file-executable-p \"" ffmpeg-bin "\")"
- "\"" ffmpeg-bin "\")"))))))
+ (substitute* '("telega-ffplay.el" "telega-vvnote.el")
+ (("(shell-command-to-string\|concat) \"(ffmpeg\|ffprobe)"
+ all func cmd)
+ (string-append func " \"" (assoc-ref inputs "ffmpeg")
+ "/bin/" cmd))
+ (("\\(executable-find \"ffplay\"\\)")
+ (string-append "(and (file-executable-p \"" ffplay-bin "\")"
+ "\"" ffplay-bin "\")"))
+ (("\\(executable-find \"ffmpeg\"\\)")
+ (string-append "(and (file-executable-p \"" ffmpeg-bin "\")"
+ "\"" ffmpeg-bin "\")"))))))
(add-after 'unpack 'configure
(lambda* (#:key inputs outputs #:allow-other-keys)
(substitute* "telega-server.el"