summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
authorXinglu Chen <public@yoctocell.xyz>2021-06-07 17:56:39 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-06-12 22:25:13 +0200
commit855805aadef94285ea38aad62d528995655e17e7 (patch)
tree8540ee3585a3aa93e5f53d2b63010d4e7fc50736 /gnu/packages/emacs-xyz.scm
parent0b73c5b89ad9ef630a4e82995ab2e6f087f4aca0 (diff)
downloadguix-patches-855805aadef94285ea38aad62d528995655e17e7.tar
guix-patches-855805aadef94285ea38aad62d528995655e17e7.tar.gz
gnu: Add emacs-ytel.
* gnu/packages/emacs-xyz.scm (emacs-ytel): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index e4a9bb8f6f..2d60c2a15d 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -21255,6 +21255,42 @@ youtube-dl backends are supported. It is possible to create download profiles
depending on the downloaded URL.")
(license license:gpl3+)))
+(define-public emacs-ytel
+ ;; No tagged releases. Using version from main file.
+ (let ((commit "d40bc7ead8d4d7e4d16b03b66a93d63bef51cc5f")
+ (revision "0"))
+ (package
+ (name "emacs-ytel")
+ (version (git-version "0.1.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/grastello/ytel")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0pxzfsxzrpv59dssrgx2mmwkm6rzk49ffjkgsa3wks7rdyfil3kf"))))
+ (build-system emacs-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-exec-paths
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((curl (assoc-ref inputs "curl")))
+ (substitute* "ytel.el"
+ (("\"curl\"") (string-append "\"" curl "/bin/curl\"")))))))))
+ (inputs
+ `(("curl" ,curl)))
+ (home-page "https://github.com/grastello/ytel")
+ (synopsis "Youtube front-end for Emacs")
+ (description
+ "This package provides a major mode to search YouTube videos via an
+Elfeed-like buffer. Information about videos displayed in this buffer can be
+extracted and manipulated by user-defined functions to do various things such
+as playing them in some video player, or downloading them.")
+ (license license:gpl3+))))
+
(define-public emacs-org-web-tools
(package
(name "emacs-org-web-tools")