summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
authorBrian Leung <bkleung89@gmail.com>2019-07-27 01:49:54 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-08-05 16:04:27 +0200
commitaca6091b05b966eaf64e16e3203cf014c53112d3 (patch)
treee52cfc488ca2cfd5d3de43989845985f101196a4 /gnu/packages/emacs-xyz.scm
parent76c2e51017124722006255453fcfae435df1de82 (diff)
downloadguix-patches-aca6091b05b966eaf64e16e3203cf014c53112d3.tar
guix-patches-aca6091b05b966eaf64e16e3203cf014c53112d3.tar.gz
gnu: emacs-highlight-indentation: Update to 0.7.0-1.d03803f.
* gnu/packages/emacs-xyz.scm (emacs-highlight-indentation): Update to 0.7.0-1.d03803f. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm45
1 files changed, 26 insertions, 19 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 85446ede4c..660752ee28 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -5580,28 +5580,35 @@ environments (virtualenv) inside Emacs.")
(license license:gpl3+)))
(define-public emacs-highlight-indentation
- (package
- (name "emacs-highlight-indentation")
- (version "0.7.0")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/antonj/Highlight-Indentation-for-Emacs.git")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "00l54k75qk24a0znzl4ij3s3nrnr2wy9ha3za8apphzlm98m907k"))))
- (build-system emacs-build-system)
- (home-page "https://github.com/antonj/Highlight-Indentation-for-Emacs/")
- (synopsis "Highlighting indentation for Emacs")
- (description "Provides two minor modes to highlight indentation guides in Emacs:
+ ;; Last release version is from 2015.
+ (let ((commit "d03803f2c06749c430443a3d24e039cbafc9c58f")
+ (revision "1"))
+ (package
+ (name "emacs-highlight-indentation")
+ (version (git-version "0.7.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/antonj/Highlight-Indentation-for-Emacs.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1jq0gf4kcx9hvrw40rnw5c2qynjpjw1vsjbi2i4lqjbsnfnxn4wz"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/antonj/Highlight-Indentation-for-Emacs/")
+ (synopsis "Highlighting indentation for Emacs")
+ (description "This package provides two minor modes to highlight
+indentation guides in Emacs:
+
@enumerate
@item @code{highlight-indentation-mode}, which displays guidelines
-indentation (space indentation only).
-@item @code{highlight-indentation-current-column-mode}, which displays guidelines for the current-point indentation (space indentation only).
+ indentation (space indentation only).
+@item @code{highlight-indentation-current-column-mode}, which displays
+ guidelines for the current-point indentation (space indentation only).
@end enumerate")
- (license license:gpl2+)))
+ (license license:gpl2+))))
(define-public emacs-elpy
(package