summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
authorNiklas Eklund <niklas.eklund@posteo.net>2022-01-22 21:46:17 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-01-23 10:28:23 +0100
commit7249b67d9c5e8d4a51dca06eab766c8411ddb29c (patch)
tree28de074639419eef0410c8404a62d4c65a71d9f1 /gnu/packages/emacs-xyz.scm
parentf041ac2f667270db387cccb8ec9bc4bc8ec6ca03 (diff)
downloadguix-patches-7249b67d9c5e8d4a51dca06eab766c8411ddb29c.tar
guix-patches-7249b67d9c5e8d4a51dca06eab766c8411ddb29c.tar.gz
gnu: emacs-dtache: Update to 0.4.
* gnu/packages/emacs-xyz.scm (emacs-dtache): Update to 0.4. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm85
1 files changed, 41 insertions, 44 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 616574e6a2..b0e7faaff7 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -23361,52 +23361,49 @@ according to their use.")
(license license:gpl3+))))
(define-public emacs-dtache
- ;; XXX: The following commit includes a fix for a test.
- (let ((commit "9e0acd552db62fb696bafb6b9ba9a78522309dd8")
- (revision "0"))
- (package
- (name "emacs-dtache")
- (version (git-version "0.3" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://gitlab.com/niklaseklund/dtache")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1jb48x33mhb4awnjrqi268wigp07j08xi02s9yhg8b04l6mnms0d"))))
- (arguments
- (list
- #:tests? #t
- #:test-command #~(list "ert-runner")
- #:phases
- #~(modify-phases %standard-phases
- (add-before 'install 'install-dtache-env
- (lambda _
- (install-file "dtache-env" (string-append #$output "/bin"))))
- (add-after 'unpack 'configure
- (lambda* (#:key inputs #:allow-other-keys)
- (make-file-writable "dtache.el")
- (emacs-substitute-variables "dtache.el"
- ("dtache-env" (string-append #$output
- "/bin/dtache-env"))
- ("dtache-dtach-program" (search-input-file
- inputs
- "/bin/dtach"))
- ("dtache-shell-program" (search-input-file
- inputs
- "/bin/bash"))))))))
- (build-system emacs-build-system)
- (native-inputs (list emacs-ert-runner))
- (inputs (list dtach))
- (home-page "https://gitlab.com/niklaseklund/dtache")
- (synopsis "Run and interact with detached shell commands")
- (description
- "The dtache package allows users to run shell commands
+ (package
+ (name "emacs-dtache")
+ (version "0.4")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/niklaseklund/dtache")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1hndv0qzibkc4177lkam30j8cgvzxd8r60v3dnqn2bmrgxw04j6b"))))
+ (arguments
+ (list
+ #:tests? #t
+ #:test-command #~(list "ert-runner")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'install 'install-dtache-env
+ (lambda _
+ (install-file "dtache-env" (string-append #$output "/bin"))))
+ (add-after 'unpack 'configure
+ (lambda* (#:key inputs #:allow-other-keys)
+ (make-file-writable "dtache.el")
+ (emacs-substitute-variables "dtache.el"
+ ("dtache-env" (string-append #$output
+ "/bin/dtache-env"))
+ ("dtache-dtach-program" (search-input-file
+ inputs
+ "/bin/dtach"))
+ ("dtache-shell-program" (search-input-file
+ inputs
+ "/bin/bash"))))))))
+ (build-system emacs-build-system)
+ (native-inputs (list emacs-ert-runner))
+ (inputs (list dtach))
+ (home-page "https://gitlab.com/niklaseklund/dtache")
+ (synopsis "Run and interact with detached shell commands")
+ (description
+ "The dtache package allows users to run shell commands
detached from Emacs. These commands are launched in sessions, using the
program dtach.")
- (license license:gpl3+))))
+ (license license:gpl3+)))
(define-public emacs-dtrt-indent
(package