summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2019-02-20 11:08:13 +0100
committerPierre Neidhardt <mail@ambrevar.xyz>2019-02-20 11:08:13 +0100
commite77c7210f002c27a6a05c65cbf4a918dbceaf237 (patch)
tree0ed25840a76fd0ba9314e0cec27355008c58e593 /gnu/packages/emacs-xyz.scm
parentbf6c8960c6094f8347c34ddbc7487877b35a5d25 (diff)
downloadguix-patches-e77c7210f002c27a6a05c65cbf4a918dbceaf237.tar
guix-patches-e77c7210f002c27a6a05c65cbf4a918dbceaf237.tar.gz
gnu: Add emacs-orgit.
* gnu/packages/emacs-xyz.scm (emacs-orgit): New variable.
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 75fc974712..3afbcd6a95 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -13158,3 +13158,30 @@ opposed to character-based).")
view of file listings sorted by size. Directory sizes are computed
recursively. The results are cached for speed.")
(license license:gpl3+)))
+
+(define-public emacs-orgit
+ (let ((commit "ddb830c38cb71e5cf86db7fa62d6ee88ab3962d5"))
+ (package
+ (name "emacs-orgit")
+ (version (git-version "1.5.1" "1" commit))
+ (home-page "https://github.com/magit/orgit")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0fy4n71yskfkjl6w9mzrw3pfd5lp8f48g2c9bxiwg7mwzsmsb9nb"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-dash" ,emacs-dash)
+ ("emacs-magit" ,emacs-magit)))
+ (synopsis "Support for Org links to Magit buffers")
+ (description "This package defines several Org link types, which can be
+used to link to certain Magit buffers. Use the command
+@command{org-store-link} while such a buffer is current to store a link.
+Later you can insert it into an Org buffer using the command
+@code{org-insert-link}.")
+ (license license:gpl3+))))