summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2021-11-26 17:43:40 +0100
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2021-12-11 09:19:30 +0100
commit01a007f46763c8ec1ccd7a560542f74585df62d3 (patch)
tree4bfff6758f3c6d0553bc922f820f283416087e0e /gnu/packages/emacs-xyz.scm
parentcfdf66e6bfc463b041965b64fc95174c90f046e0 (diff)
downloadguix-patches-01a007f46763c8ec1ccd7a560542f74585df62d3.tar
guix-patches-01a007f46763c8ec1ccd7a560542f74585df62d3.tar.gz
gnu: Add emacs-cc-mode.
* gnu/packages/emacs-xyz.scm (emacs-cc-mode): New variable.
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 8fc09eacd9..f2d21b758d 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -13862,6 +13862,39 @@ commands are bound to keys reachable with the left hand and movement keys are
reached with the right hand.")
(license license:gpl3+)))
+(define-public emacs-cc-mode
+ (package
+ (name "emacs-cc-mode")
+ (version "5.35")
+ (source
+ (origin
+ (method hg-fetch)
+ (uri (hg-reference
+ (url "http://hg.code.sf.net/p/cc-mode/cc-mode")
+ (changeset
+ (string-append "Release_"
+ (string-replace-substring version "." "_")))))
+ (file-name (hg-file-name name version))
+ (sha256
+ (base32 "03cvl61baccx57zd62nz2wy4hvij5hl2syg7byaxgrs4c7grr414"))))
+ (build-system emacs-build-system)
+ (arguments
+ '(#:tests? #t
+ #:test-command '("make" "test")
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'install 'make-info
+ (lambda _
+ (invoke "make" "info"))))))
+ (native-inputs
+ `(("texinfo" ,texinfo)))
+ (home-page "http://cc-mode.sourceforge.net/")
+ (synopsis "Framework for creating major modes for C-style languages")
+ (description
+ "CC Mode is an Emacs and XEmacs mode for editing C and other languages with
+similar syntax; currently C++, Objective-C, Java, CORBA's IDL, Pike, and AWK.")
+ (license license:gpl3+)))
+
(define-public emacs-csharp-mode
(package
(name "emacs-csharp-mode")