summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
authorMichael Rohleder <mike@rohleder.de>2020-10-04 12:17:47 +0200
committerMathieu Othacehe <othacehe@gnu.org>2020-10-06 10:07:25 +0200
commit79fa492fb5f3edd4075a19d1894dde93c2b0c0b0 (patch)
treec0b5ab4ae893d30ca05bcc83169b57074e907e60 /gnu/packages/emacs-xyz.scm
parenta6d78f2bbae64ba0be03c734871035217071112f (diff)
downloadguix-patches-79fa492fb5f3edd4075a19d1894dde93c2b0c0b0.tar
guix-patches-79fa492fb5f3edd4075a19d1894dde93c2b0c0b0.tar.gz
gnu: emacs-helpful: Update to 0.18.
* gnu/packages/emacs-xyz.scm (emacs-helpful): Update to 0.18. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm61
1 files changed, 29 insertions, 32 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 195c9a15de..aa4d3b6464 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -15869,37 +15869,34 @@ downloading manager for Emacs.")
(license license:gpl3+))))
(define-public emacs-helpful
- (let ((version "0.17")
- (commit "b0e937fff71dc0a5d34066bfd25310e76f284621")
- (revision "1"))
- (package
- (name "emacs-helpful")
- (version (git-version version revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/Wilfred/helpful")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "048qvlyj2vkgi872z8l07diwqnq21ziycv8slxzzy7rflw3wx0b2"))))
- (build-system emacs-build-system)
- (propagated-inputs
- `(("emacs-elisp-refs" ,emacs-elisp-refs)
- ("emacs-dash" ,emacs-dash)
- ("emacs-s" ,emacs-s)
- ("emacs-f" ,emacs-f)
- ("emacs-shut-up" ,emacs-shut-up)))
- (native-inputs
- `(("emacs-ert-runner" ,emacs-ert-runner)
- ("emacs-undercover" ,emacs-undercover)))
- (arguments
- `(#:tests? #t
- #:test-command '("ert-runner")))
- (home-page "https://github.com/Wilfred/helpful")
- (synopsis "More contextual information in Emacs help")
- (description "@code{helpful} is an alternative to the built-in Emacs help
+ (package
+ (name "emacs-helpful")
+ (version "0.18")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Wilfred/helpful")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0gdjxykqkal2x765mi51m99i5ql23i1fy909wy4mzj5ajhjfgqcc"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-elisp-refs" ,emacs-elisp-refs)
+ ("emacs-dash" ,emacs-dash)
+ ("emacs-s" ,emacs-s)
+ ("emacs-f" ,emacs-f)
+ ("emacs-shut-up" ,emacs-shut-up)))
+ (native-inputs
+ `(("emacs-ert-runner" ,emacs-ert-runner)
+ ("emacs-undercover" ,emacs-undercover)))
+ (arguments
+ `(#:tests? #t
+ #:test-command '("ert-runner")))
+ (home-page "https://github.com/Wilfred/helpful")
+ (synopsis "More contextual information in Emacs help")
+ (description "@code{helpful} is an alternative to the built-in Emacs help
that provides much more contextual information.
@itemize
@@ -15918,7 +15915,7 @@ functions.
@item Trace, disassemble functions from inside Helpful. This is discoverable
and doesn't require memorisation of commands.
@end itemize\n")
- (license license:gpl3+))))
+ (license license:gpl3+)))
(define-public emacs-logview
(package