summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
authorBrian Leung <bkleung89@gmail.com>2019-08-03 20:15:22 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-08-05 16:19:03 +0200
commite15ec8bcecfc3d6c4fc1f6434d11cb83ab505caa (patch)
treec6012aa3faf58d3f1c5d11b0b4121ba07d0dad3b /gnu/packages/emacs-xyz.scm
parent4d48e277cadb5ae3ba230156d7eafa118f9d3b27 (diff)
downloadguix-patches-e15ec8bcecfc3d6c4fc1f6434d11cb83ab505caa.tar
guix-patches-e15ec8bcecfc3d6c4fc1f6434d11cb83ab505caa.tar.gz
gnu: emacs-org-super-agenda: Update to 1.1.1-1.375bde4.
* gnu/packages/emacs-xyz.scm (emacs-org-super-agenda): Update to 1.1.1-1.375bde4. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm47
1 files changed, 25 insertions, 22 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 9f22a4a315..1b6e02bcbc 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -10644,29 +10644,32 @@ as well as functions for navigating between these headings.")
(license license:gpl3+)))
(define-public emacs-org-super-agenda
- (package
- (name "emacs-org-super-agenda")
- (version "1.1")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/alphapapa/org-super-agenda")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0vzf91lsxnhwf52kvm8ycpf0wb9c8l91689vyhwgv4wz8q6cvjwp"))))
- (build-system emacs-build-system)
- (propagated-inputs
- `(("emacs-org" ,emacs-org)
- ("emacs-dash" ,emacs-dash)
- ("emacs-ht" ,emacs-ht)
- ("emacs-s" ,emacs-s)))
- (home-page "https://github.com/alphapapa/org-super-agenda")
- (synopsis "Supercharged Org agenda")
- (description "This package allows items in the Org agenda to be grouped
+ ;; emacs-org-sidebar depends on a newer commit than the latest release version.
+ (let ((commit "375bde4ca72494ac88a2a9738754f047fe45cc4e")
+ (revision "1"))
+ (package
+ (name "emacs-org-super-agenda")
+ (version (git-version "1.1.1" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/alphapapa/org-super-agenda")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0hrwf02fqjm0d9gj146ax67ib76093qpqh7066dcxj2gy20625yj"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-org" ,emacs-org)
+ ("emacs-dash" ,emacs-dash)
+ ("emacs-ht" ,emacs-ht)
+ ("emacs-s" ,emacs-s)))
+ (home-page "https://github.com/alphapapa/org-super-agenda")
+ (synopsis "Supercharged Org agenda")
+ (description "This package allows items in the Org agenda to be grouped
into sections while preserving the structure imposed by any timestamps.")
- (license license:gpl3+)))
+ (license license:gpl3+))))
(define-public emacs-org-make-toc
(package