summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
authorBrian Leung <bkleung89@gmail.com>2019-08-02 06:43:00 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-08-05 16:17:46 +0200
commit4d48e277cadb5ae3ba230156d7eafa118f9d3b27 (patch)
tree7409f53888d36e885596b5702f0f8de11ec156df /gnu/packages/emacs-xyz.scm
parent003d1537834f62336cc7296b89d8c7adefdbcc39 (diff)
downloadguix-patches-4d48e277cadb5ae3ba230156d7eafa118f9d3b27.tar
guix-patches-4d48e277cadb5ae3ba230156d7eafa118f9d3b27.tar.gz
gnu: Add emacs-org-sidebar.
* gnu/packages/emacs-xyz.scm (emacs-org-sidebar): New variable. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 43290a85ed..9f22a4a315 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -4107,6 +4107,38 @@ minutes is started automatically. Every 4 breaks a long break is
started with 20 minutes. All values are customizable.")
(license license:gpl3+)))
+(define-public emacs-org-sidebar
+ (let ((commit "74ca98b9920f3de3f13d49866581435e1ec63ec5")
+ (revision "1"))
+ (package
+ (name "emacs-org-sidebar")
+ (version (git-version "0.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/alphapapa/org-sidebar.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "03p1ndyw2qp2skib5hszc4xyh84w7p2mhkd4a9dy6qv8q47xpsqn"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-dash" ,emacs-dash)
+ ("emacs-org-super-agenda" ,emacs-org-super-agenda)
+ ("emacs-org" ,emacs-org)
+ ("emacs-org-ql" ,emacs-org-ql)
+ ("emacs-s" ,emacs-s)))
+ (home-page "https://github.com/alphapapa/org-sidebar")
+ (synopsis "Helpful sidebar for Org buffers")
+ (description "This package provides a sidebar for Org buffers. At the
+top is a chronological list of scheduled and deadlined tasks in the current
+buffer (similar to the Org agenda ,but without all its features), and below
+that is a list of all other non-done to-do items. If the buffer is narrowed,
+the sidebar only shows items in the narrowed portion; this allows seeing an
+overview of tasks in a subtree.")
+ (license license:gpl3+))))
+
(define-public emacs-org-trello
(package
(name "emacs-org-trello")