summaryrefslogtreecommitdiff
path: root/gnu/packages/education.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-01-10 15:10:26 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-01-10 15:10:26 +0200
commit808e4c141ef270cf0787690fbfff906f36f164cc (patch)
tree2aa9bf2b94849de0f5729f614133367f1e32c1c0 /gnu/packages/education.scm
parentd0fff8f840afc17be40bdc49bff52ed08d5a1a7b (diff)
downloadguix-patches-808e4c141ef270cf0787690fbfff906f36f164cc.tar
guix-patches-808e4c141ef270cf0787690fbfff906f36f164cc.tar.gz
gnu: tipp10: Build with qt-5.
* gnu/packages/education.scm (tipp10)[source]: Add new patches. [inputs]: Remove qt-4, sqlite. Add qtbase, qtmultimedia. * gnu/packages/patches/tipp10-disable-downloader.patch, gnu/packages/patches/tipp10-qt5.patch: New files. * gnu/local.mk (dist_patch_DATA): Register them.
Diffstat (limited to 'gnu/packages/education.scm')
-rw-r--r--gnu/packages/education.scm11
1 files changed, 7 insertions, 4 deletions
diff --git a/gnu/packages/education.scm b/gnu/packages/education.scm
index 07862291a7..8ba673fe03 100644
--- a/gnu/packages/education.scm
+++ b/gnu/packages/education.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2016 Danny Milosavljevic <dannym@scratchpost.org>
;;; Copyright © 2016, 2017 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016 Hartmut Goebel <h.goebel@crazy-compilers.com>
-;;; Copyright © 2017, 2018, 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2017, 2018, 2019, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018, 2019, 2020 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2020 Robert Smith <robertsmith@posteo.net>
@@ -230,8 +230,11 @@ Currently available boards include:
(sha256
(base32
"0d387b404j88gsv6kv0rb7wxr23v5g5vl6s5l7602x8pxf7slbbx"))
+ ;; Apply patches in the order determined by Debian
(patches (search-patches "tipp10-fix-compiling.patch"
- "tipp10-remove-license-code.patch"))))
+ "tipp10-remove-license-code.patch"
+ "tipp10-disable-downloader.patch"
+ "tipp10-qt5.patch"))))
(build-system cmake-build-system)
(arguments
`(#:tests? #f ; packages has no tests
@@ -256,8 +259,8 @@ Currently available boards include:
;; Recreate Makefile
(invoke "qmake")))))))
(inputs
- `(("qt4" ,qt-4)
- ("sqlite" ,sqlite)))
+ `(("qtbase" ,qtbase)
+ ("qtmultimedia" ,qtmultimedia)))
(home-page "https://www.tipp10.com/")
(synopsis "Touch typing tutor")
(description "Tipp10 is a touch typing tutor. The ingenious thing about