summaryrefslogtreecommitdiff
path: root/gnu/packages/dunst.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-02-14 19:05:45 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-02-14 19:05:45 +0100
commit7edafc884c2a21258541b17a231051702c458263 (patch)
treed4202c8d6516bacd32fa55ee23c54b069ef8abd6 /gnu/packages/dunst.scm
parent89da127035737bdf922bc566970c5506c2e01b00 (diff)
parent64fc4f3705423c83c680a95d8dea81a39fce9a70 (diff)
downloadguix-patches-7edafc884c2a21258541b17a231051702c458263.tar
guix-patches-7edafc884c2a21258541b17a231051702c458263.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/dunst.scm')
-rw-r--r--gnu/packages/dunst.scm14
1 files changed, 12 insertions, 2 deletions
diff --git a/gnu/packages/dunst.scm b/gnu/packages/dunst.scm
index 75f2b80e5f..5b20d6d013 100644
--- a/gnu/packages/dunst.scm
+++ b/gnu/packages/dunst.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2015, 2017, 2018 Alex Kost <alezost@gmail.com>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -26,6 +27,7 @@
#:use-module (gnu packages base)
#:use-module (gnu packages freedesktop)
#:use-module (gnu packages glib)
+ #:use-module (gnu packages gnome)
#:use-module (gnu packages gtk)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
@@ -52,9 +54,16 @@
;; Otherwise it tries to install service file
;; to "dbus" store directory.
(string-append "SERVICEDIR_DBUS=" %output
- "/share/dbus-1/services"))
+ "/share/dbus-1/services")
+ "dunstify")
#:phases (modify-phases %standard-phases
- (delete 'configure))))
+ (delete 'configure)
+ (add-after 'install 'install-dunstify
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (install-file "dunstify"
+ (string-append out "/bin")))
+ #t)))))
(native-inputs
`(("pkg-config" ,pkg-config)
("perl" ,perl) ; for pod2man
@@ -65,6 +74,7 @@
("glib" ,glib)
("cairo" ,cairo)
("pango" ,pango)
+ ("libnotify" ,libnotify) ; for dunstify
("libx11" ,libx11)
("libxscrnsaver" ,libxscrnsaver)
("libxinerama" ,libxinerama)