summaryrefslogtreecommitdiff
path: root/gnu/packages/documentation.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-02-20 17:19:00 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-02-20 17:19:00 +0100
commit901236474a9523595c0bdefd5ac22366e78b9e61 (patch)
tree667efe648d584b0c960b0da0d577b8a71b6b941c /gnu/packages/documentation.scm
parent63d4ef52ebad4157817d56ccbe974da8fff81929 (diff)
parent64766d5cafd5cf19189ed274eb7e29ef784f90de (diff)
downloadguix-patches-901236474a9523595c0bdefd5ac22366e78b9e61.tar
guix-patches-901236474a9523595c0bdefd5ac22366e78b9e61.tar.gz
Merge branch 'staging' into core-updates
Diffstat (limited to 'gnu/packages/documentation.scm')
-rw-r--r--gnu/packages/documentation.scm13
1 files changed, 8 insertions, 5 deletions
diff --git a/gnu/packages/documentation.scm b/gnu/packages/documentation.scm
index 9425df707c..6ce7827391 100644
--- a/gnu/packages/documentation.scm
+++ b/gnu/packages/documentation.scm
@@ -123,14 +123,18 @@ markup) can be customized and extended by the user.")
(define-public doxygen
(package
(name "doxygen")
- (version "1.8.14")
+ (version "1.8.15")
+ (home-page "http://www.doxygen.nl/")
(source (origin
(method url-fetch)
- (uri (string-append "http://ftp.stack.nl/pub/users/dimitri/"
- name "-" version ".src.tar.gz"))
+ (uri (list (string-append home-page "files/doxygen-"
+ version ".src.tar.gz")
+ (string-append "mirror://sourceforge/doxygen/rel-"
+ version "/doxygen-" version
+ ".src.tar.gz")))
(sha256
(base32
- "0kcxymbam9jwiyjwyvwdjj0h74lbb6c467szsipzbxjyfl17wxfi"))
+ "0p94b4yb6bk2dxzs5kyl82xxgq2qakgbx5yy3ssbbadncb20x75x"))
(patches (search-patches "doxygen-test.patch"))))
(build-system cmake-build-system)
(native-inputs
@@ -150,7 +154,6 @@ markup) can be customized and extended by the user.")
(string-append
(assoc-ref inputs "bash") "/bin/sh")))
#t)))))
- (home-page "http://www.stack.nl/~dimitri/doxygen/")
(synopsis "Generate documentation from annotated sources")
(description "Doxygen is the de facto standard tool for generating
documentation from annotated C++ sources, but it also supports other popular