summaryrefslogtreecommitdiff
path: root/gnu/packages/documentation.scm
diff options
context:
space:
mode:
authorRaghav Gururajan <raghavgururajan@disroot.org>2020-08-07 22:44:20 -0400
committerDanny Milosavljevic <dannym@scratchpost.org>2020-08-18 23:26:14 +0200
commit22e4409473ad98e999c1ef04b4d07b5e9c2f0c82 (patch)
tree8d6b42765589b60d087289cc79988f95946fb625 /gnu/packages/documentation.scm
parent8205fe4493678cc38a95e2db8d8fcbca03b7173f (diff)
downloadguix-patches-22e4409473ad98e999c1ef04b4d07b5e9c2f0c82.tar
guix-patches-22e4409473ad98e999c1ef04b4d07b5e9c2f0c82.tar.gz
gnu: Add latex2html.
* gnu/packages/documentation.scm (latex2html): New variable. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
Diffstat (limited to 'gnu/packages/documentation.scm')
-rw-r--r--gnu/packages/documentation.scm44
1 files changed, 44 insertions, 0 deletions
diff --git a/gnu/packages/documentation.scm b/gnu/packages/documentation.scm
index 405ebcc1ed..9c30fc832a 100644
--- a/gnu/packages/documentation.scm
+++ b/gnu/packages/documentation.scm
@@ -54,6 +54,50 @@
#:use-module (gnu packages xml)
#:use-module (gnu packages xorg))
+(define-public latex2html
+ (package
+ (name "latex2html")
+ (version "2020.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/latex2html/latex2html.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1icyl6kl60wh7cavprgbd8q6lpjwr7wn24m34kpiif7ahknhcbcm"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-configure
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "configure"
+ (("/usr/local")
+ (assoc-ref outputs "out"))
+ (("\\$\\{CONFIG_SHELL-/bin/sh\\}")
+ (which "bash")))
+ #t))
+ (replace 'configure
+ (lambda _
+ (invoke "./configure")
+ #t))
+ (add-after 'configure 'patch-cfgcache
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "cfgcache.pm"
+ (("/usr/local")
+ (assoc-ref outputs "out")))
+ #t)))))
+ (inputs
+ `(("perl" ,perl)))
+ (synopsis "LaTeX documents to HTML")
+ (description "LaTeX2HTML is a utility that converts LaTeX documents to web
+pages in HTML.")
+ (home-page "https://www.latex2html.org/")
+ (license gpl2+)))
+
(define-public asciidoc
(package
(name "asciidoc")