summaryrefslogtreecommitdiff
path: root/gnu/packages/docker.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-06-19 17:38:47 +0200
committerMarius Bakke <marius@gnu.org>2021-06-19 17:38:47 +0200
commit6f9a80b331ae41d142a49fbeb94b90ee587b6155 (patch)
tree2da042a6ccf5368c73d6e3d54c2ee02a62d284e4 /gnu/packages/docker.scm
parent6500c9a5b364616e38a7e03aa4516fc2d7cee876 (diff)
parentdece03e2b98fc1c2428c2448ce5792f813eb79bf (diff)
downloadguix-patches-6f9a80b331ae41d142a49fbeb94b90ee587b6155.tar
guix-patches-6f9a80b331ae41d142a49fbeb94b90ee587b6155.tar.gz
Merge branch 'master' into core-updates
Note: this merge actually changes the 'curl' and 'python-attrs' derivations, as part of solving caf4a7a2770ef4d05a6e18f40d602e51da749ddc and 12964df69a99de6190422c752fef65ef813f3b6b respectively. 4604d43c0e (gnu: gnutls@3.6.16: Fix cross-compilation.) was ignored because it cannot currently be tested. Conflicts: gnu/local.mk gnu/packages/aidc.scm gnu/packages/boost.scm gnu/packages/curl.scm gnu/packages/nettle.scm gnu/packages/networking.scm gnu/packages/python-xyz.scm gnu/packages/tls.scm
Diffstat (limited to 'gnu/packages/docker.scm')
-rw-r--r--gnu/packages/docker.scm21
1 files changed, 8 insertions, 13 deletions
diff --git a/gnu/packages/docker.scm b/gnu/packages/docker.scm
index 6083ed780b..8bac1b89ce 100644
--- a/gnu/packages/docker.scm
+++ b/gnu/packages/docker.scm
@@ -382,12 +382,12 @@ built-in registry server of Docker.")
(("DefaultInitBinary = .*")
(string-append "DefaultInitBinary = \""
(assoc-ref inputs "tini")
- "/bin/tini\"\n")))
+ "/bin/tini-static\"\n")))
(substitute* "daemon/config/config_common_unix_test.go"
(("expectedInitPath: \"docker-init\"")
(string-append "expectedInitPath: \""
(assoc-ref inputs "tini")
- "/bin/tini\"")))
+ "/bin/tini-static\"")))
(substitute* "vendor/github.com/moby/buildkit/executor/runcexecutor/executor.go"
(("var defaultCommandCandidates = .*")
(string-append "var defaultCommandCandidates = []string{\""
@@ -716,7 +716,7 @@ defined in a per-project configuration file.")
(define-public tini
(package
(name "tini")
- (version "0.18.0")
+ (version "0.19.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -725,19 +725,14 @@ defined in a per-project configuration file.")
(file-name (git-file-name name version))
(sha256
(base32
- "1h20i3wwlbd8x4jr2gz68hgklh0lb0jj7y5xk1wvr8y58fip1rdn"))))
+ "1hnnvjydg7gi5gx6nibjjdnfipblh84qcpajc08nvr44rkzswck4"))))
(build-system cmake-build-system)
(arguments
`(#:tests? #f ;tests require a Docker daemon
- #:phases (modify-phases %standard-phases
- (add-after 'unpack 'disable-static-build
- ;; Disable the static build as it fails to install, with
- ;; the error: "No valid ELF RPATH or RUNPATH entry exists
- ;; in the file".
- (lambda _
- (substitute* "CMakeLists.txt"
- ((".*tini-static.*") ""))
- #t)))))
+ ;; 'tini-static' is a static binary, which leads CMake to fail with
+ ;; ‘file RPATH_CHANGE could not write new RPATH: ...’. Clear
+ ;; CMAKE_INSTALL_RPATH to avoid that problem.
+ #:configure-flags '("-DCMAKE_INSTALL_RPATH=")))
(home-page "https://github.com/krallin/tini")
(synopsis "Tiny but valid init for containers")
(description "Tini is an init program specifically designed for use with