summaryrefslogtreecommitdiff
path: root/gnu/packages/docker.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-08-06 10:07:36 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-08-06 10:07:36 +0200
commit378d94e51b00c30b19a39154278d01f1f3c4dbc1 (patch)
tree0c9ed3a1c1b6db778b05ad03fa8edd91cfb737f4 /gnu/packages/docker.scm
parentd350d5e71434704d147b1252d21e46daf6bb9885 (diff)
parent6a5198170ed5f10e1eee2e25fc6a39f3f33a40fd (diff)
downloadguix-patches-378d94e51b00c30b19a39154278d01f1f3c4dbc1.tar
guix-patches-378d94e51b00c30b19a39154278d01f1f3c4dbc1.tar.gz
Merge remote-tracking branch 'origin/master' into wip-texlive
Diffstat (limited to 'gnu/packages/docker.scm')
-rw-r--r--gnu/packages/docker.scm16
1 files changed, 7 insertions, 9 deletions
diff --git a/gnu/packages/docker.scm b/gnu/packages/docker.scm
index 18e7bea724..94cfa2bdb7 100644
--- a/gnu/packages/docker.scm
+++ b/gnu/packages/docker.scm
@@ -63,12 +63,13 @@
(arguments '(#:tests? #f))
(inputs
`(("python-requests" ,python-requests-2.20)
- ("python-docker-pycreds" ,python-docker-pycreds)
("python-ipaddress" ,python-ipaddress)
- ("python-paramiko" ,python-paramiko)
("python-six" ,python-six)
("python-urllib3" ,python-urllib3-1.24)
("python-websocket-client" ,python-websocket-client)))
+ (propagated-inputs
+ `(("python-docker-pycreds" ,python-docker-pycreds)
+ ("python-paramiko" ,python-paramiko))) ; adds SSH support
(home-page "https://github.com/docker/docker-py/")
(synopsis "Python client for Docker")
(description "Docker-Py is a Python client for the Docker container
@@ -113,17 +114,11 @@ client.")
;; TODO: Tests require running Docker daemon.
(arguments '(#:tests? #f))
(inputs
- `(("python2-backport-ssl-match-hostname"
- ,python2-backport-ssl-match-hostname)
- ("python-cached-property"
+ `(("python-cached-property"
,python-cached-property)
- ("python-colorama" ,python-colorama)
("python-docker-py" ,python-docker-py)
- ("python-docker-pycreds" ,python-docker-pycreds)
("python-dockerpty" ,python-dockerpty)
("python-docopt" ,python-docopt)
- ("python-ipaddress" ,python-ipaddress)
- ("python-paramiko" ,python-paramiko)
("python-jsonschema" ,python-jsonschema-2.6)
("python-pyyaml" ,python-pyyaml)
("python-requests" ,python-requests-2.20)
@@ -586,6 +581,9 @@ provisioning etc.")
;; information, and the DWARF symbol table.
(setenv "LDFLAGS" "-s -w")
+ ;; Make sure "docker -v" prints a usable version string.
+ (setenv "VERSION" ,%docker-version)
+
;; Make build reproducible.
(setenv "BUILDTIME" "1970-01-01 00:00:01.000000000+00:00")
(symlink "src/github.com/docker/cli/scripts" "./scripts")