summaryrefslogtreecommitdiff
path: root/gnu/packages/dns.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-09-19 01:00:17 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-09-19 01:40:05 +0200
commit84da8f7feede61c63dd359fc5dfb5e8d6ea09ef4 (patch)
tree3f5f9c4a3d310e0c5e9eb1baa9f4ee0c15a91aa4 /gnu/packages/dns.scm
parentdc5ccd2e4d380728ecdd3f8510db86b8a9916154 (diff)
downloadguix-patches-84da8f7feede61c63dd359fc5dfb5e8d6ea09ef4.tar
guix-patches-84da8f7feede61c63dd359fc5dfb5e8d6ea09ef4.tar.gz
gnu: knot: Update to 3.0.0.
* gnu/packages/dns.scm (knot): Update to 3.0.0. Order fields more conventionally. [source]: Remove obsolete snippet.
Diffstat (limited to 'gnu/packages/dns.scm')
-rw-r--r--gnu/packages/dns.scm57
1 files changed, 25 insertions, 32 deletions
diff --git a/gnu/packages/dns.scm b/gnu/packages/dns.scm
index 65f1c632b4..d730b14c1d 100644
--- a/gnu/packages/dns.scm
+++ b/gnu/packages/dns.scm
@@ -803,37 +803,25 @@ Extensions} (DNSSEC).")
(define-public knot
(package
(name "knot")
- (version "2.9.6")
+ (version "3.0.0")
(source
(origin
(method url-fetch)
(uri (string-append "https://secure.nic.cz/files/knot-dns/"
"knot-" version ".tar.xz"))
(sha256
- (base32 "1rxjjisr6rz1wa4279ghvj5zzhgyjhncmb9dkzqm8nw2qs1jhx5z"))
- (modules '((guix build utils)))
- (snippet
- '(begin
- ;; Delete bundled libraries.
- (with-directory-excursion "src/contrib"
- (delete-file-recursively "lmdb"))
- #t))))
+ (base32 "1i76zflc49jbsaj3idxx7a6x87c0lzal294c3fdjyfl7dvznmjgi"))))
(build-system gnu-build-system)
- (native-inputs
- `(("pkg-config" ,pkg-config)))
- (inputs
- `(("fstrm" ,fstrm)
- ("gnutls" ,gnutls)
- ("jansson" ,jansson)
- ("libcap-ng" ,libcap-ng)
- ("libedit" ,libedit)
- ("libidn" ,libidn)
- ("liburcu" ,liburcu)
- ("lmdb" ,lmdb)
- ("ncurses" ,ncurses)
- ("protobuf-c" ,protobuf-c)))
(arguments
- `(#:phases
+ `(#:configure-flags
+ (list "--sysconfdir=/etc"
+ "--localstatedir=/var"
+ "--enable-dnstap" ; let tools read/write capture files
+ "--with-module-dnstap=yes" ; detailed query capturing & logging
+ (string-append "--with-bash-completions="
+ (assoc-ref %outputs "out")
+ "/etc/bash_completion.d"))
+ #:phases
(modify-phases %standard-phases
(add-before 'configure 'disable-directory-pre-creation
(lambda _
@@ -848,15 +836,20 @@ Extensions} (DNSSEC).")
(etc (string-append doc "/examples/etc")))
(invoke "make"
(string-append "config_dir=" etc)
- "install")))))
- #:configure-flags
- (list "--sysconfdir=/etc"
- "--localstatedir=/var"
- "--enable-dnstap" ; let tools read/write capture files
- "--with-module-dnstap=yes" ; detailed query capturing & logging
- (string-append "--with-bash-completions="
- (assoc-ref %outputs "out")
- "/etc/bash_completion.d"))))
+ "install")))))))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("fstrm" ,fstrm)
+ ("gnutls" ,gnutls)
+ ("jansson" ,jansson)
+ ("libcap-ng" ,libcap-ng)
+ ("libedit" ,libedit)
+ ("libidn" ,libidn)
+ ("liburcu" ,liburcu)
+ ("lmdb" ,lmdb)
+ ("ncurses" ,ncurses)
+ ("protobuf-c" ,protobuf-c)))
(home-page "https://www.knot-dns.cz/")
(synopsis "Authoritative DNS name server")
(description "Knot DNS is an authoritative name server for the @dfn{Domain