summaryrefslogtreecommitdiff
path: root/gnu/packages/dns.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-06-19 17:38:47 +0200
committerMarius Bakke <marius@gnu.org>2021-06-19 17:38:47 +0200
commit6f9a80b331ae41d142a49fbeb94b90ee587b6155 (patch)
tree2da042a6ccf5368c73d6e3d54c2ee02a62d284e4 /gnu/packages/dns.scm
parent6500c9a5b364616e38a7e03aa4516fc2d7cee876 (diff)
parentdece03e2b98fc1c2428c2448ce5792f813eb79bf (diff)
downloadguix-patches-6f9a80b331ae41d142a49fbeb94b90ee587b6155.tar
guix-patches-6f9a80b331ae41d142a49fbeb94b90ee587b6155.tar.gz
Merge branch 'master' into core-updates
Note: this merge actually changes the 'curl' and 'python-attrs' derivations, as part of solving caf4a7a2770ef4d05a6e18f40d602e51da749ddc and 12964df69a99de6190422c752fef65ef813f3b6b respectively. 4604d43c0e (gnu: gnutls@3.6.16: Fix cross-compilation.) was ignored because it cannot currently be tested. Conflicts: gnu/local.mk gnu/packages/aidc.scm gnu/packages/boost.scm gnu/packages/curl.scm gnu/packages/nettle.scm gnu/packages/networking.scm gnu/packages/python-xyz.scm gnu/packages/tls.scm
Diffstat (limited to 'gnu/packages/dns.scm')
-rw-r--r--gnu/packages/dns.scm15
1 files changed, 8 insertions, 7 deletions
diff --git a/gnu/packages/dns.scm b/gnu/packages/dns.scm
index a0388a1419..199b876369 100644
--- a/gnu/packages/dns.scm
+++ b/gnu/packages/dns.scm
@@ -101,7 +101,7 @@
(base32 "0ac242n7996fswq1a3nlh1bbbhrsdwsq4mx7xq8ffq6aplb4rj4a"))
(patches
(search-patches
- ;; To create make-flag vairables,
+ ;; To create make-flag variables,
;; for splitting installation of drill and examples.
"ldns-drill-examples.patch"))))
(build-system gnu-build-system)
@@ -769,16 +769,16 @@ served by AS112. Stub and forward zones are supported.")
(define-public yadifa
(package
(name "yadifa")
- (version "2.4.2")
+ (version "2.5.0")
(source
- (let ((build "9997"))
+ (let ((build "10188"))
(origin
(method url-fetch)
(uri
(string-append "https://www.yadifa.eu/sites/default/files/releases/"
"yadifa-" version "-" build ".tar.gz"))
(sha256
- (base32 "0f1by2c7l39qpsar5nh98f3xypmn2ikv7wr557wmva6m0lwbl3q0")))))
+ (base32 "05ps6fif3sqn6yzkprnp1cm81f3ja4vqc0r6vh7nvzl73gv4rp2w")))))
(build-system gnu-build-system)
(native-inputs
`(("which" ,which)))
@@ -803,7 +803,8 @@ served by AS112. Stub and forward zones are supported.")
(list "--sysconfdir=/etc"
"--localstatedir=/var"
"--enable-shared" "--disable-static"
- "--disable-build-timestamp"))) ; build reproducibly
+ "--disable-build-timestamp" ; build reproducibly
+ "--enable-tcp-manager")))
(home-page "https://www.yadifa.eu/")
(synopsis "Authoritative DNS name server")
(description "YADIFA is an authoritative name server for the @dfn{Domain
@@ -1236,7 +1237,7 @@ known public suffixes.")
(define-public maradns
(package
(name "maradns")
- (version "3.5.0007")
+ (version "3.5.0020")
(source
(origin
(method url-fetch)
@@ -1244,7 +1245,7 @@ known public suffixes.")
(version-major+minor version) "/"
version "/maradns-" version ".tar.xz"))
(sha256
- (base32 "0bc19xylg4whww9qaj5i4izwxcrh0c0ja7l1pfcn2la02hlvg1a6"))))
+ (base32 "1qgabw6y2bwy6y88dikis62k789i0xh7iwxan8jmqpzvksqwjfgw"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; need to be root to run tests