summaryrefslogtreecommitdiff
path: root/gnu/packages/django.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-05-01 23:11:41 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-05-01 23:11:41 +0200
commit3b458d5462e6bbd852c2dc5c6670d5655abf53f5 (patch)
tree4f3ccec0de1c355134369333c17e948e3258d546 /gnu/packages/django.scm
parent2ca3fdc2db1aef96fbf702a2f26f5e18ce832038 (diff)
parent14da3daafc8dd92fdabd3367694c930440fd72cb (diff)
downloadguix-patches-3b458d5462e6bbd852c2dc5c6670d5655abf53f5.tar
guix-patches-3b458d5462e6bbd852c2dc5c6670d5655abf53f5.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/django.scm')
-rw-r--r--gnu/packages/django.scm9
1 files changed, 4 insertions, 5 deletions
diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index 8fd29d533a..8ea9dca16a 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -519,9 +519,9 @@ project aims to bulk update given objects using one query over Django ORM.")
(replace 'check
(lambda _
;; the next version will need "make test"
- (and (zero? (system* "flake8" "contact_form"))
- (zero? (system* "coverage" "run" "contact_form/runtests.py"))
- (zero? (system* "coverage" "report" "-m" "--fail-under" "0"))))))))
+ (invoke "flake8" "contact_form")
+ (invoke "coverage" "run" "contact_form/runtests.py")
+ (invoke "coverage" "report" "-m" "--fail-under" "0"))))))
(native-inputs
`(("python-coverage" ,python-coverage)
("python-flake8" ,python-flake8)))
@@ -577,8 +577,7 @@ entries, photos, book chapters, or anything else.")
`(#:phases
(modify-phases %standard-phases
(replace 'check
- (lambda _
- (zero? (system* "./test_project/manage.py" "test")))))))
+ (lambda _ (invoke "./test_project/manage.py" "test"))))))
(propagated-inputs
`(("python-django" ,python-django)))
(native-inputs