summaryrefslogtreecommitdiff
path: root/gnu/packages/display-managers.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-13 17:18:24 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-13 17:48:25 +0100
commit8394619baceb118df92e355377fd543bb1aa501a (patch)
tree504f07c2a9f88596a305b59ef45f941062426a52 /gnu/packages/display-managers.scm
parentaca2defe0172868295941fd9f0e97886f6e9b2d4 (diff)
downloadguix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar
guix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar.gz
gnu: Simplify package inputs.
This commit was obtained by running: ./pre-inst-env guix style without any additional argument.
Diffstat (limited to 'gnu/packages/display-managers.scm')
-rw-r--r--gnu/packages/display-managers.scm59
1 files changed, 25 insertions, 34 deletions
diff --git a/gnu/packages/display-managers.scm b/gnu/packages/display-managers.scm
index 1bfd85beae..86415bc0cf 100644
--- a/gnu/packages/display-managers.scm
+++ b/gnu/packages/display-managers.scm
@@ -74,28 +74,24 @@
"0hcdysw8ibr66vk8i7v56l0v5ijvhlq67v4460mc2xf2910g2m72"))))
(build-system qt-build-system)
(native-inputs
- `(("extra-cmake-modules" ,extra-cmake-modules)
- ("pkg-config" ,pkg-config)
- ("qttools" ,qttools)))
+ (list extra-cmake-modules pkg-config qttools))
(inputs
- `(("elogind" ,elogind)
- ("glib" ,glib)
- ("libxcb" ,libxcb)
- ("libxkbcommon" ,libxkbcommon)
- ("linux-pam" ,linux-pam)
- ("qtbase" ,qtbase-5)
- ("qtdeclarative" ,qtdeclarative)
-
- ;; Some user-defined themes use QtQuick components internally. Adding
- ;; QtQuick & co. here; they end up in QML2_IMPORT_PATH thanks to
- ;; 'wrap-qt-program'.
- ("qtgraphicaleffects" ,qtgraphicaleffects)
- ("qtquickcontrols" ,qtquickcontrols)
- ("qtquickcontrols2" ,qtquickcontrols2)
- ("qtsvg" ,qtsvg)
-
- ("shadow" ,shadow)
- ("wayland" ,wayland)))
+ (list elogind
+ glib
+ libxcb
+ libxkbcommon
+ linux-pam
+ qtbase-5
+ qtdeclarative
+ ;; Some user-defined themes use QtQuick components internally. Adding
+ ;; QtQuick & co. here; they end up in QML2_IMPORT_PATH thanks to
+ ;; 'wrap-qt-program'.
+ qtgraphicaleffects
+ qtquickcontrols
+ qtquickcontrols2
+ qtsvg
+ shadow
+ wayland))
(arguments
`(#:configure-flags
,#~(list
@@ -234,11 +230,11 @@ easy to use, login interface with a modern yet classy touch.")
(unsetenv "LC_ALL")
#t)))))
(inputs
- `(("audit" ,audit)
- ("linux-pam" ,linux-pam)
- ("shadow" ,shadow) ;for sbin/nologin
- ("libgcrypt" ,libgcrypt)
- ("libxcb" ,libxcb)))
+ (list audit
+ linux-pam
+ shadow ;for sbin/nologin
+ libgcrypt
+ libxcb))
(native-inputs
`(("gobject-introspection" ,gobject-introspection)
("pkg-config" ,pkg-config)
@@ -251,9 +247,7 @@ easy to use, login interface with a modern yet classy touch.")
("python-pygobject" ,python2-pygobject)))
;; Required by liblightdm-gobject-1.pc.
(propagated-inputs
- `(("glib" ,glib)
- ("libx11" ,libx11)
- ("libxklavier" ,libxklavier)))
+ (list glib libx11 libxklavier))
(home-page "https://www.freedesktop.org/wiki/Software/LightDM/")
(synopsis "Lightweight display manager")
(description "The Light Display Manager (LightDM) is a cross-desktop
@@ -305,10 +299,7 @@ display manager which supports different greeters.")
`("GIO_EXTRA_MODULES" ":" prefix (,gtk))))
#t)))))
(native-inputs
- `(("exo" ,exo)
- ("intltool" ,intltool)
- ("pkg-config" ,pkg-config)
- ("xfce4-dev-tools" ,xfce4-dev-tools)))
+ (list exo intltool pkg-config xfce4-dev-tools))
(inputs
`(("bash" ,bash-minimal) ; for wrap-program
("lightdm" ,lightdm)
@@ -353,7 +344,7 @@ GTK+, lets you select a desktop session and log in to it.")
("libxmu" ,libxmu)
("xauth" ,xauth)))
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ (list pkg-config))
(arguments
'(#:phases
(modify-phases %standard-phases