summaryrefslogtreecommitdiff
path: root/gnu/packages/dictionaries.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-11-07 21:33:32 +0100
committerMarius Bakke <marius@gnu.org>2020-11-07 21:33:32 +0100
commit32787d652460871a79f99b63230f92759e2e0de2 (patch)
treece883cac0d602b10b7c005755d035a08197e73a9 /gnu/packages/dictionaries.scm
parent052939c2f6e36de00a5e756ea29a4cc96884a55d (diff)
parentc2396ceb6eb30ac87755eb8b39583403b35fbd12 (diff)
downloadguix-patches-32787d652460871a79f99b63230f92759e2e0de2.tar
guix-patches-32787d652460871a79f99b63230f92759e2e0de2.tar.gz
Merge branch 'master' into staging
Conflicts: gnu/local.mk gnu/packages/gdb.scm gnu/packages/lisp-xyz.scm gnu/packages/web-browsers.scm
Diffstat (limited to 'gnu/packages/dictionaries.scm')
-rw-r--r--gnu/packages/dictionaries.scm10
1 files changed, 8 insertions, 2 deletions
diff --git a/gnu/packages/dictionaries.scm b/gnu/packages/dictionaries.scm
index f60b3f38d6..4e3c1e8803 100644
--- a/gnu/packages/dictionaries.scm
+++ b/gnu/packages/dictionaries.scm
@@ -53,14 +53,14 @@
(define-public vera
(package
(name "vera")
- (version "1.23")
+ (version "1.24")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/vera/vera-" version
".tar.gz"))
(sha256
(base32
- "1az0v563jja8xb4896jyr8yv7jd9zacqyfkjd7psb73v7clg1mzz"))))
+ "1j5p679vw72bv766acbg6g89k31ynmrzlpg7s3wzy4krlwdf92xc"))))
(build-system trivial-build-system)
(arguments
`(#:builder (begin
@@ -80,6 +80,12 @@
(mkdir-p info)
(mkdir-p html)
+ ;; Change a ‘Malformed UTF-8 character: \xd7\x34 (unexpected
+ ;; non-continuation byte 0x34, immediately after start byte
+ ;; 0xd7; need 2 bytes, got 1) in pattern match (m//)’.
+ (substitute* "vera.h"
+ (("320.480") "320x480"))
+
;; XXX: Use '--force' because the document is unhappy
;; with Texinfo 5 (yes, documents can be unhappy.)
(invoke (string-append texi "/bin/makeinfo")