summaryrefslogtreecommitdiff
path: root/gnu/packages/debug.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-09-05 21:56:34 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-09-05 22:30:04 +0300
commitde3c03a47160dec355d9b19ad5ca210d90c15fd7 (patch)
tree4ca6dc05b5fc9530d812bbb269f1c61ab9efccf3 /gnu/packages/debug.scm
parentab6fe9d362046231ad6f46eccfd1ea2c9c80b401 (diff)
parentb8477cab7bccc4191ed3dfa3f149aec7917834d8 (diff)
downloadguix-patches-de3c03a47160dec355d9b19ad5ca210d90c15fd7.tar
guix-patches-de3c03a47160dec355d9b19ad5ca210d90c15fd7.tar.gz
Merge remote-tracking branch 'origin/master' into staging
Diffstat (limited to 'gnu/packages/debug.scm')
-rw-r--r--gnu/packages/debug.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/debug.scm b/gnu/packages/debug.scm
index 2a3e6edc31..2f58f8e972 100644
--- a/gnu/packages/debug.scm
+++ b/gnu/packages/debug.scm
@@ -536,6 +536,31 @@ the position of the variable and allows you to modify its value.")
;; by GPLv3 or later.
(license (list license:lgpl3+ license:gpl3+))))
+(define-public remake
+ (package (inherit gnu-make)
+ (name "remake")
+ (version "4.3-1.5")
+ (source (origin
+ (method url-fetch)
+ (uri (let ((upstream-version
+ (match (string-split version #\-)
+ ((ver sub) (string-append ver "%2Bdbg-" sub)))))
+ (string-append "mirror://sourceforge/bashdb/"
+ "remake/" upstream-version "/"
+ "remake-" upstream-version ".tar.gz")))
+ (file-name (string-append "remake-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0xlx2485y0israv2pfghmv74lxcv9i5y65agy69mif76yc4vfvif"))
+ (patches (search-patches "remake-impure-dirs.patch"))))
+ (inputs
+ `(("readline" ,readline)
+ ,@(package-inputs gnu-make)))
+ (home-page "http://bashdb.sourceforge.net/remake/")
+ (description "Remake is an enhanced version of GNU Make that adds improved
+error reporting, better tracing, profiling, and a debugger.")
+ (license license:gpl3+)))
+
(define-public rr
(package
(name "rr")