summaryrefslogtreecommitdiff
path: root/gnu/packages/databases.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-03-09 16:35:41 +0100
committerLudovic Courtès <ludo@gnu.org>2017-03-09 16:35:41 +0100
commite90e0fad1b3ba79d81f02424e143ee6f4f736e8b (patch)
tree2c26190fd9114199b0ef79303e18a61100cab4af /gnu/packages/databases.scm
parent8ea0700d231a8819fc7e8332e9685f0ce15c174e (diff)
parent9ec2a4d3fec44f08a55df9f5f3d1a04b83e7fcf6 (diff)
downloadguix-patches-e90e0fad1b3ba79d81f02424e143ee6f4f736e8b.tar
guix-patches-e90e0fad1b3ba79d81f02424e143ee6f4f736e8b.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/databases.scm')
-rw-r--r--gnu/packages/databases.scm41
1 files changed, 36 insertions, 5 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 877eac9559..4b637f0c70 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -8,7 +8,7 @@
;;; Copyright © 2015 Sou Bunnbu <iyzsong@gmail.com>
;;; Copyright © 2015 Leo Famulari <leo@famulari.name>
;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
-;;; Copyright © 2016 ng0 <ng0@we.make.ritual.n0.is>
+;;; Copyright © 2016, 2017 ng0 <contact.ng0@cryptolab.net>
;;; Copyright © 2016 Roel Janssen <roel@gnu.org>
;;; Copyright © 2016 David Craven <david@craven.ch>
;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
@@ -252,7 +252,7 @@ SQL, Key/Value, XML/XQuery or Java Object storage for their data model.")
(define-public leveldb
(package
(name "leveldb")
- (version "1.19")
+ (version "1.20")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/google/leveldb"
@@ -260,7 +260,7 @@ SQL, Key/Value, XML/XQuery or Java Object storage for their data model.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "00jjgs9xlwycfkg0xd7n1rj6v9zrx7xc7hann6zalrjyhap18ykx"))))
+ "0r36bcrj6b2afsp4aw1gjai3jbs1c7734pxpc1jz7hh9nasyiazm"))))
(build-system gnu-build-system)
(arguments
'(#:make-flags (list "CC=gcc")
@@ -553,7 +553,7 @@ types are supported, as is encryption.")
(define-public rocksdb
(package
(name "rocksdb")
- (version "5.1.2")
+ (version "5.1.4")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/facebook/rocksdb"
@@ -561,7 +561,7 @@ types are supported, as is encryption.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "1qdbs13al7g45xc2j44wzx0ywrg32q1gsdhk5j6j4952xg91rfmh"))
+ "0ddyj8lh5jk6vx675pdg4jhgs7c12ckw5j31rz85jlrds68ygrry"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -1203,6 +1203,37 @@ and B+ Tree data storage models. It is a fast key-value lightweight
database and supports many programming languages. It is a NoSQL database.")
(license license:gpl3+)))
+(define-public tokyocabinet
+ (package
+ (name "tokyocabinet")
+ (version "1.4.48")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://fallabs.com/tokyocabinet/"
+ name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "140zvr0n8kvsl0fbn2qn3f2kh3yynfwnizn4dgbj47m975yg80x0"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags
+ (list "--enable-pthread" "--enable-off64" "--enable-fastest"
+ (string-append "LDFLAGS=-Wl,-rpath="
+ (assoc-ref %outputs "out") "/lib"))))
+ (inputs
+ `(("zlib" ,zlib)))
+ (home-page "http://fallabs.com/tokyocabinet/")
+ (synopsis "Tokyo Cabinet is a modern implementation of the DBM database")
+ (description
+ "Tokyo Cabinet is a library of routines for managing a database.
+The database is a simple data file containing records, each is a pair of a
+key and a value. Every key and value is serial bytes with variable length.
+Both binary data and character string can be used as a key and a value.
+There is neither concept of data tables nor data types. Records are
+organized in hash table, B+ tree, or fixed-length array.")
+ (license license:lgpl2.1+)))
+
(define-public wiredtiger
(package
(name "wiredtiger")