summaryrefslogtreecommitdiff
path: root/gnu/packages/databases.scm
diff options
context:
space:
mode:
authorThomas Danckaert <thomas.danckaert@gmail.com>2017-01-24 18:03:31 +0100
committerLudovic Courtès <ludo@gnu.org>2017-01-24 23:09:09 +0100
commit259a94e98102f4ad6988098229ee85c7bb648b36 (patch)
tree319f21b9134b62179acb3765861aa8c3ed246cb2 /gnu/packages/databases.scm
parentfd7d1235f1d2e053bbc20d555bd9eed889845ca2 (diff)
downloadguix-patches-259a94e98102f4ad6988098229ee85c7bb648b36.tar
guix-patches-259a94e98102f4ad6988098229ee85c7bb648b36.tar.gz
gnu: Add qdbm.
* gnu/packages/databases.scm (qdbm): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/databases.scm')
-rw-r--r--gnu/packages/databases.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index fb0266e405..e8be179801 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -14,6 +14,7 @@
;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2016 Andy Patterson <ajpatter@uwaterloo.ca>
;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -425,6 +426,33 @@ TIMESTAMP. It also supports storage of binary large objects, including
pictures, sounds, or video.")
(license (x11-style "file://COPYRIGHT"))))
+(define-public qdbm
+ (package
+ (name "qdbm")
+ (version "1.8.78")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://fallabs.com/" name "/"
+ name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0gmpvhn02pkq280ffmn4da1g4mdr1xxz7l80b7y4n7km1mrzwrml"))))
+ (build-system gnu-build-system)
+ (arguments
+ `( #:configure-flags (list (string-append "LDFLAGS=-Wl,-rpath="
+ (assoc-ref %outputs "out")
+ "/lib"))))
+ (home-page "http://fallabs.com/qdbm")
+ (synopsis "Key-value database")
+ (description "QDBM is a library of routines for managing a
+database. The database is a simple data file containing key-value
+pairs. Every key and value is serial bytes with variable length.
+Binary data as well as character strings can be used as a key or a
+value. There is no concept of data tables or data types. Records are
+organized in a hash table or B+ tree.")
+ (license license:lgpl2.1+)))
+
(define-public recutils
(package
(name "recutils")