summaryrefslogtreecommitdiff
path: root/gnu/packages/databases.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-13 14:56:29 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-31 14:54:11 -0400
commitb0193c649fa70b31c2c63f82abb7cf9309066b6c (patch)
tree62ee69c27b9e40679a99588f1d9beb608c465b9d /gnu/packages/databases.scm
parente7ccfbed19ed385c7687414beb3279d8649d9a97 (diff)
downloadguix-patches-b0193c649fa70b31c2c63f82abb7cf9309066b6c.tar
guix-patches-b0193c649fa70b31c2c63f82abb7cf9309066b6c.tar.gz
gnu: Remove 4store.
* gnu/packages/databases.scm (4store): Delete variable. * gnu/packages/patches/4store-fix-buildsystem.patch: Delete file. * gnu/packages/patches/4store-unset-preprocessor-directive.patch: Likewise. * gnu/local.mk (dist_patch_DATA): De-register them.
Diffstat (limited to 'gnu/packages/databases.scm')
-rw-r--r--gnu/packages/databases.scm41
1 files changed, 0 insertions, 41 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 56f6b92b4c..09d825af3e 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -177,47 +177,6 @@
#:use-module (srfi srfi-26)
#:use-module (ice-9 match))
-(define-public 4store
- (package
- (name "4store")
- (version "1.1.6")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/4store/4store")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "1kzdfmwpzy64cgqlkcz5v4klwx99w0jk7afckyf7yqbqb4rydmpk"))
- (patches (search-patches "4store-unset-preprocessor-directive.patch"
- "4store-fix-buildsystem.patch"))))
- (build-system gnu-build-system)
- (native-inputs
- (list perl
- python-2
- autoconf
- automake
- gettext-minimal
- libtool
- `(,pcre "bin") ;for 'pcre-config'
- pkg-config))
- (inputs
- (list glib
- rasqal
- libxml2
- raptor2
- readline
- avahi
- cyrus-sasl
- openssl
- `(,util-linux "lib")))
- ;; http://www.4store.org has been down for a while now.
- (home-page "https://github.com/4store/4store")
- (synopsis "Clustered RDF storage and query engine")
- (description "4store is a RDF/SPARQL store written in C, supporting
-either single machines or networked clusters.")
- (license license:gpl3+)))
-
(define-public ephemeralpg
(package
(name "ephemeralpg")