summaryrefslogtreecommitdiff
path: root/gnu/packages/databases.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-10-20 22:24:09 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-11 12:18:21 -0500
commitfdae245a753d77a8266764fdcc8e11434a57d046 (patch)
tree7c30945a4ef161a0821216a6bf1d46116f8abe10 /gnu/packages/databases.scm
parent12b9810ede8795ff633145ccec4dd99482865cd8 (diff)
downloadguix-patches-fdae245a753d77a8266764fdcc8e11434a57d046.tar
guix-patches-fdae245a753d77a8266764fdcc8e11434a57d046.tar.gz
gnu: mariadb: Only run the main test suite to avoid flaky tests.
Tests from the perfschema test suite has a high failure rate. Upstream only tests the main test suite in their CI, so don't try to outdo them. * gnu/packages/databases.scm (mariadb): Delete trailing #t. [phases]{check}: Only run the main test suite.
Diffstat (limited to 'gnu/packages/databases.scm')
-rw-r--r--gnu/packages/databases.scm20
1 files changed, 7 insertions, 13 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 505d5c2753..7bcc01411d 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -775,8 +775,7 @@ Language.")
(unless (string-suffix? "CMakeLists.txt" file)
(delete-file file)))
(append (find-files "extra/wolfssl")
- (find-files "zlib")))
- #t))))
+ (find-files "zlib")))))))
(build-system cmake-build-system)
(outputs '("out" "lib" "dev"))
(arguments
@@ -862,8 +861,7 @@ Language.")
"${INSTALL_INCLUDEDIR}"))
(substitute* "cmake/mariadb_connector_c.cmake"
(("\\\\\\$\\{CMAKE_INSTALL_PREFIX\\}/\\$\\{INSTALL_BINDIR\\}")
- "${INSTALL_BINDIR}"))
- #t))
+ "${INSTALL_BINDIR}"))))
(add-after 'unpack 'adjust-tests
(lambda _
(let ((disabled-tests
@@ -912,8 +910,7 @@ Language.")
(substitute* "mysql-test/mysql-test-run.pl"
(("/bin/ls") (which "ls"))
- (("/bin/sh") (which "sh")))
- #t)))
+ (("/bin/sh") (which "sh"))))))
(add-before 'configure 'disable-plugins
(lambda _
(let ((disable-plugin (lambda (name)
@@ -924,14 +921,14 @@ Language.")
(format port "\n")))))
(disabled-plugins '(;; XXX: Causes a test failure.
"disks")))
- (for-each disable-plugin disabled-plugins)
- #t)))
+ (for-each disable-plugin disabled-plugins))))
(replace 'check
(lambda* (#:key (tests? #t) parallel-tests? #:allow-other-keys)
(if tests?
(with-directory-excursion "mysql-test"
(invoke "./mtr" "--verbose"
"--retry=3"
+ "--suite=main"
"--testcase-timeout=40"
"--suite-timeout=600"
"--parallel" (number->string (if parallel-tests?
@@ -942,8 +939,7 @@ Language.")
;; failures even on powerful hardware.
"--skip-rpl"
"--skip-test-list=unstable-tests"))
- (format #t "test suite not run~%"))
- #t))
+ (format #t "test suite not run~%"))))
(add-after
'install 'post-install
(lambda* (#:key inputs outputs #:allow-other-keys)
@@ -988,9 +984,7 @@ Language.")
(substitute* (list (string-append dev "/bin/mysql_config")
(string-append dev "/lib/pkgconfig/mariadb.pc"))
(("-lssl -lcrypto" all)
- (string-append "-L" openssl "/lib " all)))
-
- #t))))))
+ (string-append "-L" openssl "/lib " all)))))))))
(native-inputs
`(("bison" ,bison)
("perl" ,perl)))