summaryrefslogtreecommitdiff
path: root/gnu/packages/databases.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2021-01-10 22:24:17 +0000
committerGuillaume Le Vaillant <glv@posteo.net>2021-01-14 10:22:50 +0100
commit0c0a2831b0c114dc5645482dcfef7f69e8a8298f (patch)
tree7d5d7908369fa2d088fa1e7c84eac8ca1a558363 /gnu/packages/databases.scm
parent4c21676698893257c75ae9a76471f2ea2df257b6 (diff)
downloadguix-patches-0c0a2831b0c114dc5645482dcfef7f69e8a8298f.tar
guix-patches-0c0a2831b0c114dc5645482dcfef7f69e8a8298f.tar.gz
gnu: Add freetds.
* gnu/packages/databases.scm (freetds): New variable. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu/packages/databases.scm')
-rw-r--r--gnu/packages/databases.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 311a0528b5..de066163ef 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -46,6 +46,7 @@
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
+;;; Copyright © 2021 Sharlatan Hellseher <sharlatanus@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -3953,3 +3954,26 @@ The drivers officially supported by @code{libdbi} are:
PostreSQL, SQLite, ODBC and MySQL.")
(home-page "http://soci.sourceforge.net/")
(license license:boost1.0)))
+
+(define-public freetds
+ (package
+ (name "freetds")
+ (version "1.2.18")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://www.freetds.org/files/stable/"
+ "freetds-" version ".tar.gz"))
+ (sha256
+ (base32 "1hspvwxwdd1apadsy2b40dpjik8kfwcvdamvhpg3lnm15n02fb50"))))
+ (build-system gnu-build-system)
+ (arguments
+ ;; NOTE: (Sharlatan-20210110213908+0000) some tests require DB connection,
+ ;; disabled for now.
+ `(#:tests? #f))
+ (home-page "https://www.freetds.org/")
+ (synopsis "Client libraries for MS SQL and Sybase servers")
+ (description
+ "FreeTDS is an implementation of the Tabular DataStream protocol, used for
+connecting to MS SQL and Sybase servers over TCP/IP.")
+ (license license:lgpl2.0+)))