summaryrefslogtreecommitdiff
path: root/gnu/packages/databases.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2017-10-10 08:42:02 +0100
committerChristopher Baines <mail@cbaines.net>2018-01-14 22:16:26 +0000
commit0076f5a98c6f88a1d1d1824592bb8886b02b1894 (patch)
treed8fd1ddb2e41b5a4b5b52e360017cecaaead2519 /gnu/packages/databases.scm
parent2c2ec3d04a36914390c7617bb9971fd840b40646 (diff)
downloadguix-patches-0076f5a98c6f88a1d1d1824592bb8886b02b1894.tar
guix-patches-0076f5a98c6f88a1d1d1824592bb8886b02b1894.tar.gz
gnu: Remove redundant wrapping from packages using ruby-build-system.
Now that the build system does wrapping automatically, it can be removed from the packages that do it manually. * gnu/packages/databases.scm (es-dump-restore)[arguments]: Remove #:phases. * gnu/packages/ruby.scm (ruby-redcloth)[arguments]: Remove #:phases. (ruby-httpclient)[arguments]: Remove 'wrap-bin-httpclient from the modified phases.
Diffstat (limited to 'gnu/packages/databases.scm')
-rw-r--r--gnu/packages/databases.scm13
1 files changed, 1 insertions, 12 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index d7bcce44e7..70202beea4 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -291,18 +291,7 @@ SQL, Key/Value, XML/XQuery or Java Object storage for their data model.")
"020yk7f1hw48clmf5501z3xv9shsdchyymcv0y2cci2c1xvr1mim"))))
(build-system ruby-build-system)
(arguments
- '(#:tests? #f ;; No testsuite.
- #:phases
- (modify-phases %standard-phases
- (add-after 'install 'wrap-bin-es_dump_restore
- (lambda* (#:key outputs #:allow-other-keys)
- (wrap-program (string-append (assoc-ref outputs "out")
- "/bin/es_dump_restore")
- `("GEM_PATH" ":" prefix (,(getenv "GEM_PATH")
- ,(string-append
- (assoc-ref outputs "out")
- "/lib/ruby/vendor_ruby"))))
- #t)))))
+ '(#:tests? #f)) ;; No testsuite.
(propagated-inputs
`(("ruby-httpclient" ,ruby-httpclient)
("ruby-multi-json" ,ruby-multi-json)