summaryrefslogtreecommitdiff
path: root/gnu/packages/databases.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-11-03 15:08:18 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2021-11-03 15:28:27 +0100
commit23489e69f29cf4f2794f4a2180a9aca01567585a (patch)
treee3cffaf5bb3a110607abaa9ae89f613e3a9f08ef /gnu/packages/databases.scm
parentccb2fabee0c0d71808a9e0c90db3f8f0f43c803f (diff)
downloadguix-patches-23489e69f29cf4f2794f4a2180a9aca01567585a.tar
guix-patches-23489e69f29cf4f2794f4a2180a9aca01567585a.tar.gz
gnu: python-sqlalchemy: Respect #:tests?.
* gnu/packages/databases.scm (python-sqlalchemy)[argument]: Respect the #:tests? keyword in the custom 'check phase.
Diffstat (limited to 'gnu/packages/databases.scm')
-rw-r--r--gnu/packages/databases.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 0404f63684..e1d639f86b 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -2995,7 +2995,9 @@ Database API 2.0T.")
`(#:phases
(modify-phases %standard-phases
(replace 'check
- (lambda _ (invoke "py.test"))))))
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "py.test")))))))
(home-page "https://www.sqlalchemy.org")
(synopsis "Database abstraction library")
(description