summaryrefslogtreecommitdiff
path: root/gnu/packages/databases.scm
diff options
context:
space:
mode:
authornixo <nicolo@nixo.xyz>2021-01-27 23:54:55 +0100
committerLudovic Courtès <ludo@gnu.org>2021-09-03 22:08:51 +0200
commitc017e0b62c3cb42a46db7f7603b63bb17c966e4a (patch)
treeea9d31f02d4f4b93302e3e3b58be61ffa9e1cc7e /gnu/packages/databases.scm
parent947b219ac5238cf5227ddc71fbedc2dd60003c9d (diff)
downloadguix-patches-c017e0b62c3cb42a46db7f7603b63bb17c966e4a.tar
guix-patches-c017e0b62c3cb42a46db7f7603b63bb17c966e4a.tar.gz
gnu: nheko: Update to 0.8.2.
* gnu/packages/messaging.scm (nheko): Update to 0.8.2. [source snippet]: Remove third_party folder. [arguments]: Remove -fpermissive flag, remove remove-Werror phase, add phase wrap-program and unbundle-dependencies. [inputs]: Add gst-plugins-base, gst-plugins-bad, libnice, qtkeychain, and unbundle blurhash, cpp-httplib and single-application, remove tweeny. [native-inputs]: Add doxygen, graphviz used to build documentation. [description]: Simplify by removing the long list, add new features. (mtxclient): Update to 0.5.1. [arguments]: Remove set-home phase. * gnu/packages/databases.scm (lmdbxx): Update to 1.0.0. [source]: Change repository to a fork required by nheko. [home-page]: Update accordingly. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/databases.scm')
-rw-r--r--gnu/packages/databases.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 884830262e..c75e1421d5 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -39,7 +39,7 @@
;;; Copyright © 2019 Pierre Langlois <pierre.langlois@gmx.com>
;;; Copyright © 2019, 2021 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2020 Pierre Neidhardt <mail@ambrevar.xyz>
-;;; Copyright © 2020 Nicolò Balzarotti <nicolo@nixo.xyz>
+;;; Copyright © 2020, 2021 Nicolò Balzarotti <nicolo@nixo.xyz>
;;; Copyright © 2020 Tanguy Le Carrour <tanguy@bioneland.org>
;;; Copyright © 2020 Lars-Dominik Braun <ldb@leibniz-psychology.org>
;;; Copyright © 2020 Guy Fleury Iteriteka <gfleury@disroot.org>
@@ -2497,16 +2497,16 @@ virtual address space — not physical RAM.")
(define-public lmdbxx
(package
(name "lmdbxx")
- (version "0.9.14.0")
+ (version "1.0.0")
(source
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/drycpp/lmdbxx")
+ (url "https://github.com/hoytech/lmdbxx")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "1jmb9wg2iqag6ps3z71bh72ymbcjrb6clwlkgrqf1sy80qwvlsn6"))))
+ (base32 "12k5rz74d1l0skcks9apry1svkl96g9lf5dcgylgjmh7v1jm0b7c"))))
(arguments
`(#:make-flags
(list (string-append "PREFIX=" (assoc-ref %outputs "out")))
@@ -2515,7 +2515,7 @@ virtual address space — not physical RAM.")
(delete 'configure))))
(build-system gnu-build-system)
(inputs `(("lmdb" ,lmdb)))
- (home-page "http://lmdbxx.sourceforge.net")
+ (home-page "https://github.com/hoytech/lmdbxx")
(synopsis "C++11 wrapper for the LMDB embedded B+ tree database library")
(description "@code{lmdbxx} is a comprehensive @code{C++} wrapper for the
@code{LMDB} embedded database library, offering both an error-checked