summaryrefslogtreecommitdiff
path: root/gnu/packages/databases.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-04 22:22:54 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-11 12:18:34 -0500
commitb045f587715f9dc11e71e267f1cf4c8fd24ae4dc (patch)
tree641abbe0b0de3ad379b784f4c10cac62e8f7643e /gnu/packages/databases.scm
parent374c6fd09c5fbcbe06e7fac2d7faac584e6dfa80 (diff)
downloadguix-patches-b045f587715f9dc11e71e267f1cf4c8fd24ae4dc.tar
guix-patches-b045f587715f9dc11e71e267f1cf4c8fd24ae4dc.tar.gz
gnu: python-aiomysql: Update to 0.17.8.
* gnu/packages/databases.scm (python-aiomysql): Update to 0.17.8. Update comment about why the tests are disabled. [native-inputs]: Remove. [propagated-inputs]{python-pypika, python-typing-extensions}: Remove. {python-asyncmy, python-asyncpg, python-iso8601, python-pypika-tortoise} {python-rapidjson, python-uvloop}: New propagated inputs. [synopsis, description]: Reformat and modify slightly.
Diffstat (limited to 'gnu/packages/databases.scm')
-rw-r--r--gnu/packages/databases.scm57
1 files changed, 22 insertions, 35 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 074a5f29a6..b7ab4578f2 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -2701,48 +2701,35 @@ of PyMySQL. @code{aiomysql} tries to preserve the same API as the
(define-public python-tortoise-orm
(package
(name "python-tortoise-orm")
- (version "0.16.21")
+ (version "0.17.8")
(source
(origin
(method url-fetch)
(uri (pypi-uri "tortoise-orm" version))
(sha256
- (base32
- "1dallk0q8q4v37klm0v3rppf2w8sjkqmypc1w8r9rraqxg1ylacp"))))
+ (base32 "1gzgiypln7lck3p95vk3i8rdx1bjbmmlcpb8xpba8cjdjvlj0l0z"))))
(build-system python-build-system)
- (arguments
- `(#:tests? #f ; Pypi does not have tests and Git snapshot depends on
- ; poetry.
- #:phases (modify-phases %standard-phases
- (add-after 'unpack 'relax-version-requirements
- (lambda _
- (substitute* "setup.py"
- (("pypika>=0\\.44\\.0,<0\\.45\\.0") "pypika")
- (("aiosqlite>=0.16.0,<0.17.0") "aiosqlite")
- (("pytz>=2020\\.4,<2021\\.0") "pytz")
- ;; Not required, since ciso8601 is used.
- (("'iso8601>=0\\.1\\.13,<0\\.2\\.0',") ""))
- #t)))))
- (native-inputs
- `(("python-asynctest" ,python-asynctest)
- ("python-nose2" ,python-nose2)))
+ ;; The test suite relies on asynctest, which is abandoned and doesn't
+ ;; support Python >= 3.8.
+ (arguments '(#:tests? #f))
(propagated-inputs
- `(("python-aiosqlite" ,python-aiosqlite)
- ("python-pypika" ,python-pypika)
- ("python-ciso8601" ,python-ciso8601)
- ("python-pytz" ,python-pytz)
- ("python-typing-extensions"
- ,python-typing-extensions)))
- (home-page
- "https://github.com/tortoise/tortoise-orm")
- (synopsis
- "Easy async ORM for python, built with relations in mind")
- (description
- "Tortoise ORM is an easy-to-use asyncio ORM (Object Relational Mapper)
-inspired by Django. Tortoise ORM was build with relations in mind and
-admiration for the excellent and popular Django ORM. It’s engraved in its
-design that you are working not with just tables, you work with relational
-data.")
+ (list python-aiomysql
+ python-aiosqlite
+ python-asyncmy
+ python-asyncpg
+ python-ciso8601
+ python-iso8601
+ python-pypika-tortoise
+ python-pytz
+ python-rapidjson
+ python-uvloop))
+ (home-page "https://github.com/tortoise/tortoise-orm")
+ (synopsis "Asynchronous Object Relational Mapper (ORM) for Python")
+ (description "Tortoise ORM is an easy-to-use asyncio ORM (Object
+Relational Mapper) inspired by Django. Tortoise ORM was built with relations
+in mind and admiration for the excellent and popular Django ORM. It's
+engraved in its design that you are working not with just tables, you work
+with relational data.")
(license license:asl2.0)))
(define-public sqlcipher