summaryrefslogtreecommitdiff
path: root/gnu/packages/databases.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-04 22:13:15 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-11 12:18:33 -0500
commit374c6fd09c5fbcbe06e7fac2d7faac584e6dfa80 (patch)
treeb91b2a17777aee016b9fefe3a69d5b4873b1cd02 /gnu/packages/databases.scm
parent0f67d46524b6048598effd3ddc2c6c7a06c633fb (diff)
downloadguix-patches-374c6fd09c5fbcbe06e7fac2d7faac584e6dfa80.tar
guix-patches-374c6fd09c5fbcbe06e7fac2d7faac584e6dfa80.tar.gz
gnu: Add python-aiomysql.
* gnu/packages/databases.scm (python-aiomysql): New variable.
Diffstat (limited to 'gnu/packages/databases.scm')
-rw-r--r--gnu/packages/databases.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index eb4414116d..074a5f29a6 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -2677,6 +2677,27 @@ reuses most of @code{pymysql} and @code{aiomysql} but rewrites the core
protocol with Cython for performance.")
(license license:asl2.0)))
+(define-public python-aiomysql
+ (package
+ (name "python-aiomysql")
+ (version "0.0.21")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "aiomysql" version))
+ (sha256
+ (base32 "0b442d0jb82z3lk19ylmm64ix88ppz7gay08bxld538ivg06j5c1"))))
+ (build-system python-build-system)
+ (arguments '(#:tests? #f)) ;test suite requires docker
+ (propagated-inputs (list python-pymysql))
+ (home-page "https://github.com/aio-libs/aiomysql")
+ (synopsis "MySQL driver for Python")
+ (description "@code{aiomysql} is a driver for accessing a MySQL database
+from the @code{asyncio} Python framework. It depends on and reuses most parts
+of PyMySQL. @code{aiomysql} tries to preserve the same API as the
+@code{aiopg} library.")
+ (license license:expat)))
+
(define-public python-tortoise-orm
(package
(name "python-tortoise-orm")