summaryrefslogtreecommitdiff
path: root/gnu/packages/databases.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-01-25 12:42:39 -0500
committerLeo Famulari <leo@famulari.name>2017-01-25 12:42:39 -0500
commitd123f2f991e0bf6f51e5f207d291fb4c1ceb1245 (patch)
tree8ca3cbeff8a08ab9e11a0324fd9ec0bae7614f4c /gnu/packages/databases.scm
parenta282d7ff174ccc13b3645359449af6052451c2a1 (diff)
parent864042c5c5f845fd3c1ae37c64dc1a672fedef28 (diff)
downloadguix-patches-d123f2f991e0bf6f51e5f207d291fb4c1ceb1245.tar
guix-patches-d123f2f991e0bf6f51e5f207d291fb4c1ceb1245.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/databases.scm')
-rw-r--r--gnu/packages/databases.scm32
1 files changed, 30 insertions, 2 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index c2efc072bf..2638b229df 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -14,6 +14,7 @@
;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2016 Andy Patterson <ajpatter@uwaterloo.ca>
;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -425,6 +426,33 @@ TIMESTAMP. It also supports storage of binary large objects, including
pictures, sounds, or video.")
(license (x11-style "file://COPYRIGHT"))))
+(define-public qdbm
+ (package
+ (name "qdbm")
+ (version "1.8.78")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://fallabs.com/" name "/"
+ name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0gmpvhn02pkq280ffmn4da1g4mdr1xxz7l80b7y4n7km1mrzwrml"))))
+ (build-system gnu-build-system)
+ (arguments
+ `( #:configure-flags (list (string-append "LDFLAGS=-Wl,-rpath="
+ (assoc-ref %outputs "out")
+ "/lib"))))
+ (home-page "http://fallabs.com/qdbm")
+ (synopsis "Key-value database")
+ (description "QDBM is a library of routines for managing a
+database. The database is a simple data file containing key-value
+pairs. Every key and value is serial bytes with variable length.
+Binary data as well as character strings can be used as a key or a
+value. There is no concept of data tables or data types. Records are
+organized in a hash table or B+ tree.")
+ (license license:lgpl2.1+)))
+
(define-public recutils
(package
(name "recutils")
@@ -1050,7 +1078,7 @@ database and supports many programming languages. It is a NoSQL database.")
(define-public wiredtiger
(package
(name "wiredtiger")
- (version "2.8.0")
+ (version "2.9.1")
(source (origin
(method url-fetch)
(uri (string-append
@@ -1058,7 +1086,7 @@ database and supports many programming languages. It is a NoSQL database.")
version ".tar.bz2"))
(sha256
(base32
- "1qh7y5paisdxq19jgg81ld7i32lz920n5k30hdpxnr8ll9c4hgjr"))))
+ "0krwnb2zfbhvjaskwl875qzd3y626s84zcciq2mxr5c5riw3yh6s"))))
(build-system gnu-build-system)
(arguments
'(#:configure-flags '("--enable-lz4" "--enable-zlib")