summaryrefslogtreecommitdiff
path: root/gnu/packages/curl.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2023-04-25 15:19:29 +0200
committerAndreas Enge <andreas@enge.fr>2023-04-25 15:19:29 +0200
commitc919bfefd98bf2e29549539b4e28e6dc2a8a6f32 (patch)
tree61d10f1fcc6f80d97f788e19df7f20ff7fc27752 /gnu/packages/curl.scm
parentce0bdceb4948d5f297327a1b1724074ca960eb05 (diff)
parent472706ae2f9160833951a4e4bcc4c206e03097b0 (diff)
downloadguix-patches-c919bfefd98bf2e29549539b4e28e6dc2a8a6f32.tar
guix-patches-c919bfefd98bf2e29549539b4e28e6dc2a8a6f32.tar.gz
Merge remote-tracking branch 'origin/master' into core-updates
Diffstat (limited to 'gnu/packages/curl.scm')
-rw-r--r--gnu/packages/curl.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/curl.scm b/gnu/packages/curl.scm
index 74a3132f00..b55e560a1a 100644
--- a/gnu/packages/curl.scm
+++ b/gnu/packages/curl.scm
@@ -14,6 +14,7 @@
;;; Copyright © 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2021 Jean-Baptiste Volatier <jbv@pm.me>
;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
+;;; Copyright © 2023 Sharlatan Hellseher <sharlatanus@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -381,3 +382,39 @@ curl, curlie is what you are searching for. Curlie is a frontend to
on features and performance. All @code{curl} options are exposed with syntax
sugar and output formatting inspired from @code{httpie}.")
(license license:expat)))
+
+(define-public trurl
+ (package
+ (name "trurl")
+ (version "0.5")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/curl/trurl")
+ (commit (string-append name "-" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1mvkpjs6wnz5hzmp2iglik85zljrzglsa6fm839l78fhw89dg3w6"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:test-target "test"
+ #:make-flags #~(list (string-append "CC=" #$(cc-for-target))
+ (string-append "PREFIX=" #$output))
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure))))
+ (native-inputs (list python))
+ ;; Tests failed on older curl version
+ ;; (see https://github.com/curl/trurl/pull/165)
+ (inputs (list curl-7.84.0))
+ (home-page "https://curl.se/trurl/")
+ (synopsis "Command line tool for URL parsing and manipulatio")
+ (description "@code{trurl} is a tool in a similar spirit of @code{tr} but
+for URLs. Here, @code{tr} stands for translate or transpose.
+
+@code{trurl} is a command line tool that parses and manipulates URLs, designed
+to help shell script authors everywhere.")
+ (license (license:non-copyleft "file://COPYING"
+ "See COPYING in the distribution."))))