summaryrefslogtreecommitdiff
path: root/gnu/packages/curl.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2014-08-07 22:53:21 +0200
committerAndreas Enge <andreas@enge.fr>2014-08-07 22:53:21 +0200
commit87806dde17b1b3877487ed574cfc5f841e031675 (patch)
tree33112a774849ea3681112b80e441dfc7afe66c3a /gnu/packages/curl.scm
parent75f6f74f1567661d53caebaa95f744cad86289eb (diff)
downloadguix-patches-87806dde17b1b3877487ed574cfc5f841e031675.tar
guix-patches-87806dde17b1b3877487ed574cfc5f841e031675.tar.gz
gnu: curl: Update to 7.37.1.
* gnu/packages/curl.scm (curl): Update to 7.37.1. Remove patch. * gnu/packages/patches/curl-fix-test172.patch: Remove file. * gnu-system.am (dist_patch_DATA): Remove patch.
Diffstat (limited to 'gnu/packages/curl.scm')
-rw-r--r--gnu/packages/curl.scm10
1 files changed, 3 insertions, 7 deletions
diff --git a/gnu/packages/curl.scm b/gnu/packages/curl.scm
index 7309da61e6..727c57d611 100644
--- a/gnu/packages/curl.scm
+++ b/gnu/packages/curl.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2013, 2014 Andreas Enge <andreas@enge.fr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -37,18 +37,14 @@
(define-public curl
(package
(name "curl")
- (version "7.35.0")
+ (version "7.37.1")
(source (origin
(method url-fetch)
(uri (string-append "http://curl.haxx.se/download/curl-"
version ".tar.lzma"))
(sha256
(base32
- "14w5cwh6b1426lxkq6kp6h4vxryr4n7wfrrwhny1r4123q7n8ab9"))
- (patches
- ;; This patch fixes testcase 172 which uses a hardcoded cookie
- ;; expiration value which is expired as of Feb 1, 2014.
- (list (search-patch "curl-fix-test172.patch")))))
+ "10yfh4hy8wbkj43la238hg6h8i9wyp1cvvk8kl0giac1020imn5d"))))
(build-system gnu-build-system)
(inputs `(("gnutls" ,gnutls)
("gss" ,gss)