summaryrefslogtreecommitdiff
path: root/gnu/packages/curl.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-08-10 15:32:51 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-08-10 15:32:51 +0200
commit7b38f045c04fe69001ff5c2f04486cc51a69ae82 (patch)
treebd839f1f635dc114c84d67c1db09b74f613ec315 /gnu/packages/curl.scm
parent369d15674c8bb251c45a45466031a2da1640df9f (diff)
parent256d5c6e339d59287284bb83f35c594f13bd08f9 (diff)
downloadguix-patches-7b38f045c04fe69001ff5c2f04486cc51a69ae82.tar
guix-patches-7b38f045c04fe69001ff5c2f04486cc51a69ae82.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/curl.scm')
-rw-r--r--gnu/packages/curl.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/curl.scm b/gnu/packages/curl.scm
index e724fd147b..1907d2dc3d 100644
--- a/gnu/packages/curl.scm
+++ b/gnu/packages/curl.scm
@@ -157,19 +157,19 @@ tunneling, and so on.")
(define-public kurly
(package
(name "kurly")
- (version "1.2.1")
+ (version "1.2.2")
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/davidjpeacock/kurly.git")
+ (url "https://gitlab.com/davidjpeacock/kurly.git")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
(base32
- "01kp33gvzxmk6ipz7323wqwmbc90q2mwzsjig8rzpqsm4kji5hi6"))))
+ "003jv2k45hg2svhjpy5253ccd250vi2r17x2zhm51iw54kgwxipm"))))
(build-system go-build-system)
(arguments
- `(#:import-path "github.com/davidjpeacock/kurly"
+ `(#:import-path "gitlab.com/davidjpeacock/kurly"
#:install-source? #f
#:phases
(modify-phases %standard-phases
@@ -182,20 +182,20 @@ tunneling, and so on.")
(with-directory-excursion source
(install-file "README.md" doc)
(mkdir-p man)
- (copy-file "meta/kurly.man"
+ (copy-file "doc/kurly.man"
(string-append man "/kurly.1")))
#t))))))
(inputs
`(("go-github-com-alsm-ioprogress" ,go-github-com-alsm-ioprogress)
("go-github-com-aki237-nscjar" ,go-github-com-aki237-nscjar)
- ("go-github-com-davidjpeacock-cli" ,go-github-com-davidjpeacock-cli)))
+ ("go-github-com-urfave-cli" ,go-github-com-urfave-cli)))
(synopsis "Command-line HTTP client")
(description "kurly is an alternative to the @code{curl} program written in
Go. kurly is designed to operate in a similar manner to curl, with select
features. Notably, kurly is not aiming for feature parity, but common flags and
mechanisms particularly within the HTTP(S) realm are to be expected. kurly does
not offer a replacement for libcurl.")
- (home-page "https://github.com/davidjpeacock/kurly")
+ (home-page "https://gitlab.com/davidjpeacock/kurly")
(license license:asl2.0)))
(define-public guile-curl