summaryrefslogtreecommitdiff
path: root/gnu/packages/crypto.scm
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-07-08 18:38:25 +0200
committerMathieu Othacehe <othacehe@gnu.org>2021-07-08 21:20:17 +0200
commitf78a09f0c4f73073109e7b7ab2cb7b66c48599e6 (patch)
tree8e7d2fd9216547a290b0293af2dc0fba9739fcb6 /gnu/packages/crypto.scm
parentf78975c8e098e38494a697aa88c9ca5395975041 (diff)
downloadguix-patches-f78a09f0c4f73073109e7b7ab2cb7b66c48599e6.tar
guix-patches-f78a09f0c4f73073109e7b7ab2cb7b66c48599e6.tar.gz
gnu: libolm: Respect "--without-tests".
* gnu/packages/libolm.scm (libolm)[arguments]<#:phases>{check}: Respect #:tests?. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/crypto.scm')
-rw-r--r--gnu/packages/crypto.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/crypto.scm b/gnu/packages/crypto.scm
index 99455dc632..bd2c462b96 100644
--- a/gnu/packages/crypto.scm
+++ b/gnu/packages/crypto.scm
@@ -20,6 +20,7 @@
;;; Copyright © 2020 Hendur Saga <hendursaga@yahoo.com>
;;; Copyright © 2020 pukkamustard <pukkamustard@posteo.net>
;;; Copyright © 2021 Ellis Kenyő <me@elken.dev>
+;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1314,9 +1315,10 @@ Trusted comments are signed, thus verified, before being displayed.")
`(#:phases
(modify-phases %standard-phases
(replace 'check
- (lambda _
- (with-directory-excursion "tests"
- (invoke "ctest" ".")))))))
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (with-directory-excursion "tests"
+ (invoke "ctest" "."))))))))
(synopsis "Implementation of the olm and megolm cryptographic ratchets")
(description "The libolm library implements the Double Ratchet
cryptographic ratchet. It is written in C and C++11, and exposed as a C