summaryrefslogtreecommitdiff
path: root/gnu/packages/crates-web.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-01-22 21:13:59 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-02-20 13:58:13 +0200
commitdc2615df33a73eae4c015458709e944cb99f4b99 (patch)
treed2b9584dadfefe8ad2ff6eac195ea7fe29ab92b7 /gnu/packages/crates-web.scm
parentb5fb44a86b117c3484ca465914a77792ba495dec (diff)
downloadguix-patches-dc2615df33a73eae4c015458709e944cb99f4b99.tar
guix-patches-dc2615df33a73eae4c015458709e944cb99f4b99.tar.gz
gnu: rust-trust-dns-native-tls-0.19: Update to 0.19.7.
* gnu/packages/crates-web.scm (rust-trust-dns-native-tls-0.19): Update to 0.19.7. [arguments]: Don't skip the tests. Add cargo-test-flags. Change-Id: I1d3e79c030f7fd9024e88f58254d1c84b0797df2
Diffstat (limited to 'gnu/packages/crates-web.scm')
-rw-r--r--gnu/packages/crates-web.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/crates-web.scm b/gnu/packages/crates-web.scm
index fc7026fc14..6d189004ce 100644
--- a/gnu/packages/crates-web.scm
+++ b/gnu/packages/crates-web.scm
@@ -2650,7 +2650,7 @@ extension for the Trust-DNS client to use native-tls for TLS.")
(package
(inherit rust-trust-dns-native-tls-0.20)
(name "rust-trust-dns-native-tls")
- (version "0.19.5")
+ (version "0.19.7")
(source
(origin
(method url-fetch)
@@ -2658,9 +2658,12 @@ extension for the Trust-DNS client to use native-tls for TLS.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "173443yivsiyzvnai4h53v71br8jsz4zjwhp83q3x4hnh6306ymv"))))
+ "12rh378g144cmw8lpjnivndknlf56i4lzfwnhigp1zviyw5jb7lj"))))
(arguments
- `(#:tests? #false
+ `(#:cargo-test-flags
+ '("--release" "--"
+ ;; Not all files included.
+ "--skip=tests::test_tls_client_stream_ipv4")
#:cargo-inputs
(("rust-futures" ,rust-futures-0.3)
("rust-native-tls" ,rust-native-tls-0.2)