summaryrefslogtreecommitdiff
path: root/gnu/packages/crates-io.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2021-07-05 09:32:43 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-07-05 09:32:43 +0200
commitfe565ffa2213819216b042d929ecd220378ced34 (patch)
treed49b28506549b4459dcf6f28aea4a7c83473a402 /gnu/packages/crates-io.scm
parent220c8dc25b26bef2d5d0e049d2d151a52c3f181d (diff)
downloadguix-patches-fe565ffa2213819216b042d929ecd220378ced34.tar
guix-patches-fe565ffa2213819216b042d929ecd220378ced34.tar.gz
gnu: Add rust-serde-value-0.7.
* gnu/packages/crates-io.scm (rust-serde-value-0.7): New variable. (rust-serde-value-0.6): Inherit from above.
Diffstat (limited to 'gnu/packages/crates-io.scm')
-rw-r--r--gnu/packages/crates-io.scm26
1 files changed, 22 insertions, 4 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 450cfff936..0f0f68e24a 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -41065,22 +41065,22 @@ the application/x-www-form-urlencoded format.")
#:cargo-development-inputs
(("rust-serde-derive" ,rust-serde-derive-1))))))
-(define-public rust-serde-value-0.6
+(define-public rust-serde-value-0.7
(package
(name "rust-serde-value")
- (version "0.6.0")
+ (version "0.7.0")
(source
(origin
(method url-fetch)
(uri (crate-uri "serde-value" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "1swh6870pr1cxr6ha769rv4wdnyfxdvsc42cmvf8lmla38lsfras"))))
+ (base32 "0b18ngk7n4f9zmwsfdkhgsp31192smzyl5z143qmx1qi28sa78gk"))))
(build-system cargo-build-system)
(arguments
`(#:skip-build? #t
#:cargo-inputs
- (("rust-ordered-float" ,rust-ordered-float-1)
+ (("rust-ordered-float" ,rust-ordered-float-2)
("rust-serde" ,rust-serde-1))))
(home-page "https://github.com/arcnmx/serde-value")
(synopsis "Serialization value trees")
@@ -41089,6 +41089,24 @@ the application/x-www-form-urlencoded format.")
for later processing.")
(license license:expat)))
+(define-public rust-serde-value-0.6
+ (package
+ (inherit rust-serde-value-0.7)
+ (name "rust-serde-value")
+ (version "0.6.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "serde-value" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1swh6870pr1cxr6ha769rv4wdnyfxdvsc42cmvf8lmla38lsfras"))))
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs
+ (("rust-ordered-float" ,rust-ordered-float-1)
+ ("rust-serde" ,rust-serde-1))))))
+
(define-public rust-serde-yaml-0.8
(package
(name "rust-serde-yaml")