summaryrefslogtreecommitdiff
path: root/gnu/packages/crates-io.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2021-10-06 21:49:17 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-11-03 23:00:56 +0100
commit4bbb2248c429f5008458b77639fa05c2830b8157 (patch)
treef515ec8d059938c70af556f4941b4155619535c4 /gnu/packages/crates-io.scm
parentbc85e5c072c3b3406906e698edf9e30a7993bb3c (diff)
downloadguix-patches-4bbb2248c429f5008458b77639fa05c2830b8157.tar
guix-patches-4bbb2248c429f5008458b77639fa05c2830b8157.tar.gz
gnu: Add rust-polars-core-0.16.
* gnu/packages/crates-io.scm (rust-polars-core-0.16): New variable. (rust-polars-core-0.15): Inherit from above.
Diffstat (limited to 'gnu/packages/crates-io.scm')
-rw-r--r--gnu/packages/crates-io.scm50
1 files changed, 44 insertions, 6 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index da623510e5..f167677546 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -35841,24 +35841,24 @@ applications.")
("rust-num" ,rust-num-0.4)
("rust-thiserror" ,rust-thiserror-1))))))
-(define-public rust-polars-core-0.15
+(define-public rust-polars-core-0.16
(package
(name "rust-polars-core")
- (version "0.15.1")
+ (version "0.16.0")
(source
(origin
(method url-fetch)
(uri (crate-uri "polars-core" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "0vzyyqg0s6h3k77z7nkmqrrgnp7nbi7sh5nmlw1ggrlml9ps0aa9"))))
+ (base32 "0knhxc2b0k5jpvm7fxm64b5hjdyqgxjjyi6cnsiy5sya3mj3v9cd"))))
(build-system cargo-build-system)
(arguments
`(#:skip-build? #t
#:cargo-inputs
(("rust-ahash" ,rust-ahash-0.7)
("rust-anyhow" ,rust-anyhow-1)
- ("rust-arrow" ,rust-arrow-5)
+ ("rust-arrow2" ,rust-arrow2-0.5)
("rust-chrono" ,rust-chrono-0.4)
("rust-comfy-table" ,rust-comfy-table-1)
("rust-hashbrown" ,rust-hashbrown-0.11)
@@ -35868,8 +35868,7 @@ applications.")
("rust-ndarray" ,rust-ndarray-0.15)
("rust-num" ,rust-num-0.4)
("rust-num-cpus" ,rust-num-cpus-1)
- ("rust-parquet" ,rust-parquet-5)
- ("rust-polars-arrow" ,rust-polars-arrow-0.15)
+ ("rust-polars-arrow" ,rust-polars-arrow-0.16)
("rust-prettytable-rs" ,rust-prettytable-rs-0.8)
("rust-rand" ,rust-rand-0.7)
("rust-rand-distr" ,rust-rand-distr-0.3)
@@ -35885,6 +35884,45 @@ applications.")
"This crate provides the core of the Polars DataFrame library.")
(license license:expat)))
+(define-public rust-polars-core-0.15
+ (package
+ (inherit rust-polars-core-0.16)
+ (name "rust-polars-core")
+ (version "0.15.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "polars-core" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0vzyyqg0s6h3k77z7nkmqrrgnp7nbi7sh5nmlw1ggrlml9ps0aa9"))))
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs
+ (("rust-ahash" ,rust-ahash-0.7)
+ ("rust-anyhow" ,rust-anyhow-1)
+ ("rust-arrow" ,rust-arrow-5)
+ ("rust-chrono" ,rust-chrono-0.4)
+ ("rust-comfy-table" ,rust-comfy-table-1)
+ ("rust-hashbrown" ,rust-hashbrown-0.11)
+ ("rust-itertools" ,rust-itertools-0.10)
+ ("rust-jsonpath-lib" ,rust-jsonpath-lib-0.3)
+ ("rust-lazy-static" ,rust-lazy-static-1)
+ ("rust-ndarray" ,rust-ndarray-0.15)
+ ("rust-num" ,rust-num-0.4)
+ ("rust-num-cpus" ,rust-num-cpus-1)
+ ("rust-parquet" ,rust-parquet-5)
+ ("rust-polars-arrow" ,rust-polars-arrow-0.15)
+ ("rust-prettytable-rs" ,rust-prettytable-rs-0.8)
+ ("rust-rand" ,rust-rand-0.7)
+ ("rust-rand-distr" ,rust-rand-distr-0.3)
+ ("rust-rayon" ,rust-rayon-1)
+ ("rust-regex" ,rust-regex-1)
+ ("rust-serde" ,rust-serde-1)
+ ("rust-serde-json" ,rust-serde-json-1)
+ ("rust-thiserror" ,rust-thiserror-1)
+ ("rust-unsafe-unwrap" ,rust-unsafe-unwrap-0.1))))))
+
(define-public rust-polars-core-0.14
(package
(inherit rust-polars-core-0.15)