summaryrefslogtreecommitdiff
path: root/gnu/packages/crates-io.scm
diff options
context:
space:
mode:
authorVagrant Cascadian <vagrant@debian.org>2021-12-30 20:44:21 -0800
committerVagrant Cascadian <vagrant@debian.org>2021-12-30 20:54:47 -0800
commit9c3c68dae4605a443158910a70320a7625c02efe (patch)
treebd198658ca782b7c6b2aa7fb391e3b88ac325cfa /gnu/packages/crates-io.scm
parent036ee2638c443889669ac5053f23576e8d86387a (diff)
downloadguix-patches-9c3c68dae4605a443158910a70320a7625c02efe.tar
guix-patches-9c3c68dae4605a443158910a70320a7625c02efe.tar.gz
gnu: Remove leading article from synopsis.
* gnu/packages/admin.scm (hungrycat)[synopsis]: Remove leading article. * gnu/packages/cobol.scm (gnucobol)[synopsis]: Likewise. * gnu/packages/cpp.scm (clipper)[synopsis]: Likewise. * gnu/packages/crates-graphics.scm (rust-piston-texture-0.8)[synopsis]: Likewise. * gnu/packages/crates-io.scm (rust-alloc-stdlib-0.2, rust-atom-0.3, rust-oorandom-11.1, rust-r2d2, rust-scheduled-thread-pool-0.2, rust-takeable-option-0.4, rust-ttf-parser-0.12, rust-svd-parser-0.9)[synopsis]: Likewise. * gnu/packages/games.scm (roguebox-adventures)[synopsis]: Likewise. * gnu/packages/gl.scm (libepoxy)[synopsis]: Likewise. * gnu/packages/gnome-xyz.scm (arc-theme)[synopsis]: Likewise. * gnu/packages/haskell-xyz.scm (ghc-cborg-json, ghc-rio)[synopsis]: Likewise. * gnu/packages/installers.scm (mingw-path)[synopsis]: Likewise. * gnu/packages/lisp-xyz.scm (sbcl-cl-utilities)[synopsis]: Likewise. * gnu/packages/lisp.scm (gcl, clisp)[synopsis]: Likewise. * gnu/packages/maths.scm (coda)[synopsis]: Likewise. * gnu/packages/ocaml.scm (ocaml4.07-ppx-sexp-message)[synopsis]: Likewise. * gnu/packages/perl6.scm (perl6-json)[synopsis]: Likewise. * gnu/packages/python-xyz.scm (python-pari-jupyter, python-markuppy, python-febelfin-coda)[synopsis]: Likewise. * gnu/packages/scheme.scm (mit-scheme)[synopsis]: Likewise. * gnu/packages/statistics.scm (r-magrittr)[synopsis]: Likewise. * gnu/packages/terminals.scm (sakura)[synopsis]: Likewise.
Diffstat (limited to 'gnu/packages/crates-io.scm')
-rw-r--r--gnu/packages/crates-io.scm16
1 files changed, 8 insertions, 8 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index eb385f846f..937d5f4adf 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -1903,7 +1903,7 @@ options to use calloc or a mutable global variable for pre-zeroed memory.")
`(#:cargo-inputs
(("rust-alloc-no-stdlib" ,rust-alloc-no-stdlib-2))))
(home-page "https://github.com/dropbox/rust-alloc-no-stdlib")
- (synopsis "A dynamic allocator example that may be used with the stdlib")
+ (synopsis "dynamic allocator example that may be used with the stdlib")
(description "This package provides a dynamic allocator example that may
be used with the stdlib.")
(license license:bsd-3)))
@@ -4196,7 +4196,7 @@ methods.")
"1qig9fcdqf07mzzpkicm5wgxv0zpr28njdsqf708wxq27yf6k1iw"))))
(build-system cargo-build-system)
(home-page "https://github.com/slide-rs/atom")
- (synopsis "A safe abstraction around AtomicPtr")
+ (synopsis "safe abstraction around AtomicPtr")
(description "This package provides a safe abstraction around AtomicPtr.")
(license license:asl2.0)))
@@ -35208,7 +35208,7 @@ contents.")
(build-system cargo-build-system)
(arguments `(#:skip-build? #t))
(home-page "https://hg.sr.ht/~icefox/oorandom")
- (synopsis "A tiny, robust PRNG implementation")
+ (synopsis "tiny, robust PRNG implementation")
(description
"This package provides a tiny, robust PRNG implementation.")
(license license:expat)))
@@ -41548,7 +41548,7 @@ data.")
("rust-parking-lot" ,rust-parking-lot-0.11)
("rust-scheduled-thread-pool" ,rust-scheduled-thread-pool-0.2))))
(home-page "https://github.com/sfackler/r2d2")
- (synopsis "A generic connection pool")
+ (synopsis "generic connection pool")
(description "This package provides a generic connection pool.")
(license (list license:expat license:asl2.0))))
@@ -47164,7 +47164,7 @@ server functionality.")
`(#:cargo-inputs
(("rust-parking-lot" ,rust-parking-lot-0.11))))
(home-page "https://github.com/sfackler/scheduled-thread-pool")
- (synopsis "A scheduled thread pool")
+ (synopsis "scheduled thread pool")
(description "This package provides a scheduled thread pool.")
(license (list license:expat license:asl2.0))))
@@ -54559,7 +54559,7 @@ without a mutable reference.")
"0hvd6vk4ksgg2y99498jw52ric4lxm0i6ygpzqm95gdrhvsxyynp"))))
(build-system cargo-build-system)
(home-page "https://docs.rs/takeable-option/")
- (synopsis "A small wrapper around option")
+ (synopsis "small wrapper around option")
(description
"This package provides a small wrapper around option.")
(license (list license:asl2.0 license:expat))))
@@ -60320,7 +60320,7 @@ the Trust-DNS client to use rustls for TLS.")
(build-system cargo-build-system)
(arguments `(#:skip-build? #t))
(home-page "https://github.com/RazrFalcon/ttf-parser")
- (synopsis "A high-level, safe, zero-allocation TrueType font parser")
+ (synopsis "high-level, safe, zero-allocation TrueType font parser")
(description
"This package provides a high-level, safe, zero-allocation TrueType font
parser.")
@@ -65368,7 +65368,7 @@ file into an in-memory tree structure.")
#:cargo-development-inputs
(("rust-serde-json" ,rust-serde-json-1))))
(home-page "https://github.com/rust-embedded/svd")
- (synopsis "A CMSIS-SVD file parser")
+ (synopsis "CMSIS-SVD file parser")
(description
"This package provides a CMSIS-SVD file parser")
(license (list license:expat license:asl2.0))))