summaryrefslogtreecommitdiff
path: root/gnu/packages/crates-io.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2021-12-27 18:41:19 +0100
committerLeo Famulari <leo@famulari.name>2021-12-28 14:10:21 -0500
commit63da93f9bfa22b11e3a0c713dfd542667bf77012 (patch)
tree735c0f3ee60b74d96ad505c9207d959e721717a6 /gnu/packages/crates-io.scm
parent4c0c2a15fdb41b7327a19aa473adf46c7141f816 (diff)
downloadguix-patches-63da93f9bfa22b11e3a0c713dfd542667bf77012.tar
guix-patches-63da93f9bfa22b11e3a0c713dfd542667bf77012.tar.gz
gnu: Add rust-hash32-0.2.
* gnu/packages/crates-io.scm (rust-hash32-0.2): New variable. (rust-hash32-0.1): Inherit from above.
Diffstat (limited to 'gnu/packages/crates-io.scm')
-rw-r--r--gnu/packages/crates-io.scm32
1 files changed, 24 insertions, 8 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index c5673f6503..5e0c9641c9 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -22733,29 +22733,45 @@ the template engine that renders the official Rust website")
already-hashed or hash-like data.")
(license (list license:asl2.0 license:expat))))
-(define-public rust-hash32-0.1
+(define-public rust-hash32-0.2
(package
(name "rust-hash32")
- (version "0.1.1")
+ (version "0.2.1")
(source
(origin
(method url-fetch)
(uri (crate-uri "hash32" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32
- "1k7lv7hsbzv14pz90cxay6v7avh6d6kcrra0rsc45b33dvw1l16l"))))
+ (base32 "0rrbv5pc5b1vax6j6hk7zvlrpw0h6aybshxy9vbpgsrgfrc5zhxh"))))
(build-system cargo-build-system)
(arguments
- `(#:cargo-inputs
- (("rust-byteorder" ,rust-byteorder-1))
- #:cargo-development-inputs
- (("rust-hash32-derive" ,rust-hash32-derive-0.1))))
+ `(#:skip-build? #t
+ #:cargo-inputs
+ (("rust-byteorder" ,rust-byteorder-1))))
(home-page "https://github.com/japaric/hash32")
(synopsis "32-bit hashing machinery")
(description "This package provides 32-bit hashing machinery.")
(license (list license:expat license:asl2.0))))
+(define-public rust-hash32-0.1
+ (package
+ (inherit rust-hash32-0.2)
+ (name "rust-hash32")
+ (version "0.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "hash32" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1k7lv7hsbzv14pz90cxay6v7avh6d6kcrra0rsc45b33dvw1l16l"))))
+ (arguments
+ `(#:cargo-inputs
+ (("rust-byteorder" ,rust-byteorder-1))
+ #:cargo-development-inputs
+ (("rust-hash32-derive" ,rust-hash32-derive-0.1))))))
+
(define-public rust-hash32-derive-0.1
(package
(name "rust-hash32-derive")